pkg-download: VERIFY_HASH: use same hash file for host and target downloads
authorPeter Korsgaard <peter@korsgaard.com>
Mon, 8 Dec 2014 07:50:14 +0000 (08:50 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 8 Dec 2014 07:52:25 +0000 (08:52 +0100)
Fixes (or atleast stops the build with a saner description):
http://autobuild.buildroot.net/results/1a9/1a9643f8633db038d4fe5ca4a32e4d52e70a3a1a/

We're using the same sources for host and target downloads, so it makes
sense to use the same <pkg>.hash file as well to ensure the host version
gets verified without us having to maintain a seperate host-<pkg>.hash file.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/pkg-download.mk

index f3409bd46ea5f683cbe3cc87dafed40d5322964f..190b5b7e99e63f005ce4d8803dfad0b0f86cf5bd 100644 (file)
@@ -174,7 +174,7 @@ define DOWNLOAD_SCP
        $(EXTRA_ENV) support/download/wrapper scp \
                $(DL_DIR)/$(2) \
                '$(call stripurischeme,$(call qstrip,$(1)))' && \
-       $(call VERIFY_HASH,$(PKGDIR)/$($(PKG)_NAME).hash,$(DL_DIR)/$(2))
+       $(call VERIFY_HASH,$(PKGDIR)/$($(PKG)_RAWNAME).hash,$(DL_DIR)/$(2))
 endef
 
 define SOURCE_CHECK_SCP
@@ -211,7 +211,7 @@ define DOWNLOAD_WGET
        $(EXTRA_ENV) support/download/wrapper wget \
                $(DL_DIR)/$(2) \
                '$(call qstrip,$(1))' && \
-       $(call VERIFY_HASH,$(PKGDIR)/$($(PKG)_NAME).hash,$(DL_DIR)/$(2))
+       $(call VERIFY_HASH,$(PKGDIR)/$($(PKG)_RAWNAME).hash,$(DL_DIR)/$(2))
 endef
 
 define SOURCE_CHECK_WGET
@@ -227,7 +227,7 @@ define DOWNLOAD_LOCALFILES
        $(EXTRA_ENV) support/download/wrapper cp \
                $(DL_DIR)/$(2) \
                $(call stripurischeme,$(call qstrip,$(1))) && \
-       $(call VERIFY_HASH,$(PKGDIR)/$($(PKG)_NAME).hash,$(DL_DIR)/$(2))
+       $(call VERIFY_HASH,$(PKGDIR)/$($(PKG)_RAWNAME).hash,$(DL_DIR)/$(2))
 endef
 
 define SOURCE_CHECK_LOCALFILES