libevas: really fix x86 cpu optimization options handling
authorPeter Korsgaard <jacmet@sunsite.dk>
Mon, 30 Jan 2012 22:22:51 +0000 (23:22 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 30 Jan 2012 22:22:51 +0000 (23:22 +0100)
Disable all options by default, and only enable the applicable one.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/efl/libevas/libevas.mk

index 6ad1126e772e4c12c4dfedee95b4d8aadfe5379a..acb2f4bd9db53eabbe497af3ad872a019d3990b3 100644 (file)
@@ -94,6 +94,9 @@ endif
 
 # code options
 ifeq ($(BR2_i386)$(BR2_x86_64),y)
+# defaults
+LIBEVAS_CONF_OPT += --disable-cpu-mmx --disable-cpu-sse --disable-cpu-sse3
+
 # enable if cpu variant has mmx support
 ifneq ($(BR2_x86_i386)$(BR2_x86_i486)$(BR2_x86_i586)$(BR2_x86_i686)$(BR2_x86_pentiumpro)$(BR2_x86_geode),y)
 LIBEVAS_CONF_OPT += --enable-cpu-mmx
@@ -103,14 +106,8 @@ LIBEVAS_CONF_OPT += --enable-cpu-sse
 
 ifneq ($(BR2_x86_pentium3)$(BR2_x86_pentium4)$(BR2_x86_prescott)$(BR2_x86_athlon_4)$(BR2_x86_opteron)$(BR2_x86_c32)$(BR2_x86_64_opteron),y)
 LIBEVAS_CONF_OPT += --enable-cpu-sse3
-else
-LIBEVAS_CONF_OPT += --disable-cpu-sse3
 endif # sse3
-else
-LIBEVAS_CONF_OPT += --disable-cpu-sse
 endif # sse
-else
-LIBEVAS_CONF_OPT += --disable-cpu-mmx
 endif # mmx
 endif # x86