webkitgtk: move JSC JIT selection logic to kconfig
authorAdrian Perez de Castro <aperez@igalia.com>
Tue, 9 Oct 2018 22:08:49 +0000 (01:08 +0300)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 10 Oct 2018 19:21:46 +0000 (21:21 +0200)
This is done in preparation to enable the JavaScriptCore JIT support
for more platforms. Having the logic in Config.in scales better than
checking in the .mk file.

Signed-off-by: Adrian Perez de Castro <aperez@igalia.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/webkitgtk/Config.in
package/webkitgtk/webkitgtk.mk

index 96a7ab0c941380b60678ee418a6c76ef5e496486..6933248bd6fe88bd40704fb67b109761ad4ad298 100644 (file)
@@ -11,6 +11,14 @@ config BR2_PACKAGE_WEBKITGTK_ARCH_SUPPORTS
        depends on BR2_TOOLCHAIN_HAS_SYNC_4
        depends on BR2_PACKAGE_LIBGPG_ERROR_ARCH_SUPPORTS # libgcrypt
 
+config BR2_PACKAGE_WEBKITGTK_ARCH_SUPPORTS_JIT
+       bool
+       # ARM needs NEON for JIT.
+       default y if BR2_ARM_CPU_HAS_NEON
+       # i386 & x86_64 don't have any special requirements.
+       default y if BR2_i386
+       default y if BR2_x86_64
+
 comment "webkitgtk needs libgtk3 and a glibc toolchain w/ C++, gcc >= 6, host gcc >= 4.8"
        depends on BR2_PACKAGE_WEBKITGTK_ARCH_SUPPORTS
        depends on !BR2_PACKAGE_LIBGTK3 || !BR2_INSTALL_LIBSTDCPP || \
index f28417ac730b6b1631ac8a8dcad40a7516909193..39d681b1d40fb22d55981cd73317a3c0f0d100a5 100644 (file)
@@ -27,9 +27,7 @@ WEBKITGTK_CONF_OPTS = \
        -DUSE_LIBNOTIFY=OFF \
        -DUSE_LIBHYPHEN=OFF
 
-# ARM needs NEON for JIT
-# i386 & x86_64 don't seem to have any special requirements
-ifeq ($(BR2_ARM_CPU_HAS_NEON)$(BR2_i386)$(BR2_x86_64),y)
+ifeq ($(BR2_PACKAGE_WEBKITGTK_ARCH_SUPPORTS_JIT),y)
 WEBKITGTK_CONF_OPTS += -DENABLE_JIT=ON
 else
 WEBKITGTK_CONF_OPTS += -DENABLE_JIT=OFF