samba4: remove compilation of .pyc files
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 17 May 2016 21:19:16 +0000 (23:19 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 26 May 2016 20:08:36 +0000 (22:08 +0200)
Now that .py files are globally compiled into .pyc files, we can get
rid of the samba4 specific logic doing this compilation.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Reviewed-by: Samuel Martin <s.martin49@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/samba4/samba4.mk

index 9ccc6a7104c880c0e5a78f399d2bd06e6205b400..bb546f0837334fdbdcd9ad466aa0d8909155dbd7 100644 (file)
@@ -118,16 +118,6 @@ define SAMBA4_INSTALL_TARGET_CMDS
        $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) DESTDIR=$(TARGET_DIR) install
 endef
 
-# Samba just installs .py files so the purge causes problems with some tools
-ifeq ($(BR2_PACKAGE_PYTHON_PYC_ONLY),y)
-define SAMBA4_BUILD_PYC_FILES
-       PYTHONPATH="$(PYTHON_PATH)" \
-               $(HOST_DIR)/usr/bin/python -c "import compileall; \
-               compileall.compile_dir('$(TARGET_DIR)/usr/lib/python$(PYTHON_VERSION_MAJOR)/site-packages/samba')"
-endef
-SAMBA4_POST_INSTALL_TARGET_HOOKS += SAMBA4_BUILD_PYC_FILES
-endif
-
 ifeq ($(BR2_PACKAGE_SAMBA4_AD_DC),)
 SAMBA4_CONF_OPTS += --without-ad-dc
 endif