powerpc-utils: bump to v1.3.1, change upstream location and license
authorVasant Hegde <hegdevasant@linux.vnet.ibm.com>
Wed, 30 Mar 2016 05:50:38 +0000 (11:20 +0530)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 30 Mar 2016 14:38:01 +0000 (16:38 +0200)
This patch makes below changes to powerpc-utils package:
  - Update to latest upstream version (v1.3.1)
  - Update License (from CPL to GPLv2)
  - Update source link (from SF to github)
  - Disable librtas by default
  - Finally make necessary adjustment to compile the source
    (run autogen.sh before ./configure as we don't have configure in new tarball).

RTAS:
  This package contains few tools (like nvram, ppc64_cpu, etc) which are not
  dependent on RTAS support. Traditionally we always had RTAS support (at least
  on IBM Power system). But now a days we do have environments like PowerNV host
  where we do not have RTAS support. Instead we use OPAL for runtime service [1].
  Hence lets disable RTAS by default. If someone wants to build powerpc-utils
  with RTAS they can enable it.

[1] https://github.com/open-power/skiboot.git

Signed-off-by: Vasant Hegde <hegdevasant@linux.vnet.ibm.com>
[Thomas: re-add hash file, fix license, it's GPLv2+, improve commit title.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/powerpc-utils/Config.in
package/powerpc-utils/powerpc-utils.hash
package/powerpc-utils/powerpc-utils.mk

index e18254c1240893124c23775eae5592fe0c88376e..4037c55c61ce5cee30d162af8b291785c646567e 100644 (file)
@@ -10,7 +10,7 @@ config BR2_PACKAGE_POWERPC_UTILS
        help
          System utilities for PowerPC machines.
 
-         http://sourceforge.net/projects/powerpc-utils/
+         https://github.com/nfont/powerpc-utils
 
 if BR2_PACKAGE_POWERPC_UTILS
 
@@ -18,7 +18,6 @@ config BR2_PACKAGE_POWERPC_UTILS_RTAS
        bool "RTAS support"
        select BR2_PACKAGE_LIBRTAS
        depends on BR2_TOOLCHAIN_USES_GLIBC
-       default y
        help
          Enable support for functions that require RTAS.
 
index d02f16ad6ba760f4b9103d1aaa9ba76846054b08..9e299da38a5e496a149e08b885635def79b80be5 100644 (file)
@@ -1,3 +1,2 @@
-# From http://sourceforge.net/projects/powerpc-utils/files/powerpc-utils/
-sha1   975c668e8eaedd5222a7870e82ce295d06dfe649        powerpc-utils-1.2.24.tar.gz
-md5    f492a72f2d4522eba5d9b329c84b3ed3        powerpc-utils-1.2.24.tar.gz
+# Locally calculated
+sha256 657790a4aea7f3e4649a454b4c384e255145bff9b9c5e40402170603980a6736 powerpc-utils-v1.3.1.tar.gz
index ae4d6622eca586f09b72ad3b19ec3578e0a833b2..036be52dc3d00e17c9b859ca091d31f9033095a4 100644 (file)
@@ -4,11 +4,12 @@
 #
 ################################################################################
 
-POWERPC_UTILS_VERSION = 1.2.24
-POWERPC_UTILS_SITE = http://downloads.sourceforge.net/project/powerpc-utils/powerpc-utils
+POWERPC_UTILS_VERSION = v1.3.1
+POWERPC_UTILS_SITE = $(call github,nfont,powerpc-utils,$(POWERPC_UTILS_VERSION))
 POWERPC_UTILS_DEPENDENCIES = zlib
-POWERPC_UTILS_LICENSE = Common Public License Version 1.0
-POWERPC_UTILS_LICENSE_FILES = COPYRIGHT
+POWERPC_UTILS_AUTORECONF = YES
+POWERPC_UTILS_LICENSE = GPLv2+
+POWERPC_UTILS_LICENSE_FILES = COPYING
 
 POWERPC_UTILS_CONF_ENV = \
        ax_cv_check_cflags___fstack_protector_all=$(if $(BR2_TOOLCHAIN_HAS_SSP),yes,no)