neardal: add support for ncl tool
authorSimon Dawson <spdawson@gmail.com>
Fri, 26 Apr 2013 00:25:26 +0000 (00:25 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 26 Apr 2013 10:39:18 +0000 (12:39 +0200)
[Peter: move directly under neardal option so it gets indented]
Signed-off-by: Simon Dawson <spdawson@gmail.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/neardal/Config.in
package/neardal/neardal.mk

index 045ccee1612725ab119751c893074aab396668a8..76b5ffa50abaeb78a4e666c09414454b9463486e 100644 (file)
@@ -11,5 +11,11 @@ config BR2_PACKAGE_NEARDAL
 
          https://github.com/connectivity/neardal
 
+config BR2_PACKAGE_NEARDAL_NCL
+       bool "ncl tool"
+       depends on BR2_PACKAGE_NEARDAL
+       help
+         Build and install neardal ncl command line interpreter tool.
+
 comment "neardal requires a toolchain with WCHAR and threads support"
        depends on !BR2_USE_WCHAR || !BR2_TOOLCHAIN_HAS_THREADS
index 9625f0ebfa39e0aaa6b59668f9c14b6b73832cdc..b937acb814874141577f00a353e418e2b6c2851c 100644 (file)
@@ -14,4 +14,12 @@ NEARDAL_LICENSE_FILES = COPYING
 NEARDAL_DEPENDENCIES = host-pkgconf dbus dbus-glib
 NEARDAL_AUTORECONF = YES
 
+define NEARDAL_INSTALL_NCL
+       $(INSTALL) -m 0755 -D $(@D)/ncl/ncl $(TARGET_DIR)/usr/bin/ncl
+endef
+
+ifeq ($(BR2_PACKAGE_NEARDAL_NCL),y)
+       NEARDAL_POST_INSTALL_TARGET_HOOKS += NEARDAL_INSTALL_NCL
+endif
+
 $(eval $(autotools-package))