nghttp2: new package
authorMichaël Burtin <michael.burtin@netgem.com>
Thu, 19 Jul 2018 13:54:08 +0000 (15:54 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 19 Jul 2018 14:59:42 +0000 (16:59 +0200)
nghttp2 is an implementation of HTTP/2 and its header
compression algorithm HPACK in C.

Signed-off-by: Michaël Burtin <michael.burtin@netgem.com>
Signed-off-by: Anisse Astier <anisse.astier.ext@netgem.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/Config.in
package/nghttp2/Config.in [new file with mode: 0644]
package/nghttp2/nghttp2.hash [new file with mode: 0644]
package/nghttp2/nghttp2.mk [new file with mode: 0644]

index 3f92cab4fd83442f373faa785567ac77c796f4a3..3605032da3ec3f58b2bb7075829b5db7f1e404bf 100644 (file)
@@ -157,6 +157,7 @@ F:  package/sysdig/
 
 N:     Anisse Astier <anisse@astier.eu>
 F:     package/go/
+F:     package/nghttp2/
 
 N:     Anthony Viallard <viallard@syscom-instruments.com>
 F:     package/gnuplot/
index 08a3eac48ad0d08f2f00f3d01f019c04f458917f..f5a17492c75dabb2719b987850be012b5de4f7cf 100644 (file)
@@ -1481,6 +1481,7 @@ menu "Networking"
        source "package/mongoose/Config.in"
        source "package/nanomsg/Config.in"
        source "package/neon/Config.in"
+       source "package/nghttp2/Config.in"
        source "package/norm/Config.in"
        source "package/nss-mdns/Config.in"
        source "package/nss-pam-ldapd/Config.in"
diff --git a/package/nghttp2/Config.in b/package/nghttp2/Config.in
new file mode 100644 (file)
index 0000000..03fe71d
--- /dev/null
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_NGHTTP2
+       bool "nghttp2"
+       help
+         nghttp2 is an implementation of HTTP/2 and its header
+         compression algorithm HPACK in C.
+
+         https://nghttp2.org/
diff --git a/package/nghttp2/nghttp2.hash b/package/nghttp2/nghttp2.hash
new file mode 100644 (file)
index 0000000..d000fd5
--- /dev/null
@@ -0,0 +1,3 @@
+# Locally calculated
+sha256 f75e8f228217f23aa5eabfbab140e061cda00b7c21e34c891ecfb248d663303f  nghttp2-1.32.0.tar.gz
+sha256 6b94f3abc1aabd0c72a7c7d92a77f79dda7c8a0cb3df839a97890b4116a2de2a  COPYING
diff --git a/package/nghttp2/nghttp2.mk b/package/nghttp2/nghttp2.mk
new file mode 100644 (file)
index 0000000..20bfee7
--- /dev/null
@@ -0,0 +1,22 @@
+################################################################################
+#
+# nghttp2
+#
+################################################################################
+
+NGHTTP2_VERSION = 1.32.0
+NGHTTP2_SITE = https://github.com/nghttp2/nghttp2/releases/download/v$(NGHTTP2_VERSION)
+NGHTTP2_LICENSE = MIT
+NGHTTP2_LICENSE_FILES = COPYING
+NGHTTP2_INSTALL_STAGING = YES
+NGHTTP2_DEPENDENCIES = host-pkgconf
+NGHTTP2_CONF_OPTS = --enable-lib-only
+
+define NGHTTP2_INSTALL_CLEAN_HOOK
+       # Remove fetch-ocsp-response script unused by library
+       $(Q)$(RM) -rf $(TARGET_DIR)/usr/share/nghttp2
+endef
+
+NGHTTP2_POST_INSTALL_TARGET_HOOKS += NGHTTP2_INSTALL_CLEAN_HOOK
+
+$(eval $(autotools-package))