ifplugd: ensure directories exist before installing to them
authorDanomi Manchego <danomimanchego123@gmail.com>
Thu, 24 Oct 2013 01:05:49 +0000 (21:05 -0400)
committerPeter Korsgaard <peter@korsgaard.com>
Thu, 24 Oct 2013 06:43:28 +0000 (08:43 +0200)
Add the -D to install commands to ensure that all the necessary
installation directories exist.

Signed-off-by: Danomi Manchego <danomimanchego123@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/ifplugd/ifplugd.mk

index ee5bd25ebed9671fc3c8fbf3437a3929f1243f8e..837e0160ed88ef83cfb4a90239b84e646886ea50 100644 (file)
@@ -21,14 +21,13 @@ ifeq ($(BR2_PACKAGE_BUSYBOX),y)
 endif
 
 define IFPLUGD_INSTALL_FIXUP
-       $(INSTALL) -d $(TARGET_DIR)/etc/ifplugd
        @if [ ! -f $(TARGET_DIR)/etc/ifplugd/ifplugd.conf ]; then \
-               $(INSTALL) $(@D)/conf/ifplugd.conf $(TARGET_DIR)/etc/ifplugd/; \
+               $(INSTALL) -D $(@D)/conf/ifplugd.conf $(TARGET_DIR)/etc/ifplugd/ifplugd.conf; \
                $(SED) 's^\(ARGS=.*\)w^\1^' $(TARGET_DIR)/etc/ifplugd/ifplugd.conf; \
        fi
-       $(INSTALL) -m 0755 $(@D)/conf/ifplugd.action \
-               $(TARGET_DIR)/etc/ifplugd/
-       $(INSTALL) -m 0755 $(@D)/conf/ifplugd.init \
+       $(INSTALL) -D -m 0755 $(@D)/conf/ifplugd.action \
+               $(TARGET_DIR)/etc/ifplugd/ifplugd.action
+       $(INSTALL) -D -m 0755 $(@D)/conf/ifplugd.init \
                $(TARGET_DIR)/etc/init.d/S45ifplugd
        # don't use bash for init script
        $(SED) 's^/bin/bash^/bin/sh^g' $(TARGET_DIR)/etc/init.d/S45ifplugd