package/pinentry: add pinentry-fltk
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Thu, 9 Jan 2020 19:06:04 +0000 (20:06 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Fri, 10 Jan 2020 21:30:25 +0000 (22:30 +0100)
pinentry-fltk has been added in version 1.1.0 with
https://github.com/gpg/pinentry/commit/6c45eed62214b44fcc11e642b19df7b6ca0da0bd

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/pinentry/Config.in
package/pinentry/pinentry.mk

index 518e3ad37fd04505c165abf249faec5d6f46ef13..9048edd21bedd19f7d374d3a129cd93e662588f3 100644 (file)
@@ -15,6 +15,19 @@ menuconfig BR2_PACKAGE_PINENTRY
 
 if BR2_PACKAGE_PINENTRY
 
+config BR2_PACKAGE_PINENTRY_FLTK
+       bool "pinentry-fltk"
+       depends on BR2_USE_MMU # fltk
+       depends on BR2_INSTALL_LIBSTDCPP # fltk
+       depends on BR2_PACKAGE_XORG7 # fltk
+       select BR2_PACKAGE_FLTK
+       help
+         The pinentry-fltk tool
+
+comment "pinentry-fltk needs X and a toolchain w/ C++"
+       depends on BR2_USE_MMU
+       depends on !BR2_PACKAGE_XORG7 || !BR2_INSTALL_LIBSTDCPP
+
 config BR2_PACKAGE_PINENTRY_NCURSES
        bool "pinentry-ncurses"
        select BR2_PACKAGE_NCURSES
index 0e9dfb2f0e30c3a964e9019a2cddbb5c2033ec3b..1bc1adab1765ad75e5dbe0a4d452aadc9506b358 100644 (file)
@@ -36,6 +36,15 @@ else
 PINENTRY_CONF_OPTS += --disable-libsecret
 endif
 
+# pinentry-fltk backend
+ifeq ($(BR2_PACKAGE_PINENTRY_FLTK),y)
+PINENTRY_CONF_ENV += ac_cv_path_FLTK_CONFIG=$(STAGING_DIR)/usr/bin/fltk-config
+PINENTRY_CONF_OPTS += --enable-pinentry-fltk
+PINENTRY_DEPENDENCIES += fltk
+else
+PINENTRY_CONF_OPTS += --disable-pinentry-fltk
+endif
+
 # pinentry-ncurses backend
 ifeq ($(BR2_PACKAGE_PINENTRY_NCURSES),y)
 PINENTRY_CONF_OPTS += --enable-ncurses --with-ncurses-include-dir=none