flann: bump version to fix build with gcc 6
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 17 May 2016 21:23:48 +0000 (23:23 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 24 May 2016 15:39:34 +0000 (17:39 +0200)
The current version of flann in Buildroot fails to build with gcc 6.x,
with the following failure:

  error: call of overloaded 'abs(flann::KDTreeIndex<flann::L2<float> >::ElementType)' is ambiguous

By bumping the upstream version one commit further, we get an upstream
fix that fixes the build problem.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/flann/flann.mk

index 8af58e3465126588292764baa1ca0441bbc91a9b..af86a02f044ad6e1811069f696859334b1dc7afd 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-FLANN_VERSION = 04b4a56533faf8c8228d011d05ba376038364b49
+FLANN_VERSION = 3645f0c30a47267e56e5acdecfc7bac2b76bc3d5
 FLANN_SITE = $(call github,mariusmuja,flann,$(FLANN_VERSION))
 FLANN_INSTALL_STAGING = YES
 FLANN_LICENSE = BSD-3c