package/vtun: fix static linking with atomic
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Thu, 10 Oct 2019 17:56:28 +0000 (19:56 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 10 Oct 2019 19:32:17 +0000 (21:32 +0200)
Fixes:
 - http://autobuild.buildroot.org/results/908707cdd16c5b89197c226a3e259f8943a5474e

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/vtun/vtun.mk

index 86d452c0c2a8a904c432d2caa2a1b27d651627cd..35b0ddedbbb000ffaa7d147be5fa51c72412e696 100644 (file)
@@ -8,7 +8,7 @@ VTUN_VERSION = 3.0.4
 VTUN_SITE = http://downloads.sourceforge.net/project/vtun/vtun/$(VTUN_VERSION)
 VTUN_LICENSE = GPL-2.0+ with OpenSSL exception
 VTUN_LICENSE_FILES = README.OpenSSL
-VTUN_DEPENDENCIES = host-bison host-flex zlib lzo openssl
+VTUN_DEPENDENCIES = host-bison host-flex host-pkgconf zlib lzo openssl
 VTUN_AUTORECONF = YES
 
 VTUN_CONF_OPTS = \
@@ -19,4 +19,8 @@ VTUN_CONF_OPTS = \
 # Assumes old-style gcc inline symbol visibility rules
 VTUN_CONF_ENV = CFLAGS="$(TARGET_CFLAGS) -std=gnu89"
 
+# configure.in forgets to link to dependent libraries of openssl breaking static
+# linking
+VTUN_CONF_ENV += LIBS=`$(PKG_CONFIG_HOST_BINARY) --libs openssl`
+
 $(eval $(autotools-package))