package/openvmtools: use libtirpc when toolchain has no native RPC
authorSimon Rowe <simon.rowe@citrix.com>
Thu, 25 Jul 2019 08:30:21 +0000 (09:30 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Fri, 26 Jul 2019 21:11:22 +0000 (23:11 +0200)
openvmtools detects and uses an external RPC library if RPC is not
supported by the toolchain C library, so let's select package/libtirpc
when necessary.

Signed-off-by: Simon Rowe <simon.rowe@citrix.com>
[Thomas: add missing dependency on libtirpc]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/openvmtools/Config.in
package/openvmtools/openvmtools.mk

index 97860f8c6f57bf7e00a4e8ef1fb24b4d2b9e505b..2bd5c272a9d5e0c6f0b5b39ae97c026a592911b6 100644 (file)
@@ -4,11 +4,11 @@ config BR2_PACKAGE_OPENVMTOOLS
        depends on BR2_USE_MMU # libglib2
        depends on BR2_USE_WCHAR # libglib2
        depends on BR2_TOOLCHAIN_HAS_THREADS # libglib2
-       depends on BR2_TOOLCHAIN_HAS_NATIVE_RPC
        depends on BR2_ENABLE_LOCALE
        depends on !BR2_TOOLCHAIN_USES_UCLIBC
        select BR2_PACKAGE_LIBGLIB2
        select BR2_PACKAGE_LIBDNET
+       select BR2_PACKAGE_LIBTIRPC if !BR2_TOOLCHAIN_HAS_NATIVE_RPC
        help
          Open Virtual Machine Tools for VMware guest OS
 
@@ -61,9 +61,9 @@ comment "resolutionkms needs udev, a toolchain w/ threads"
 
 endif
 
-comment "openvmtools needs a glibc or musl toolchain w/ wchar, threads, RPC, locale"
+comment "openvmtools needs a glibc or musl toolchain w/ wchar, threads, locale"
        depends on BR2_i386 || BR2_x86_64
        depends on BR2_USE_MMU
        depends on !BR2_USE_WCHAR || !BR2_TOOLCHAIN_HAS_THREADS || \
-               !BR2_TOOLCHAIN_HAS_NATIVE_RPC || !BR2_ENABLE_LOCALE || \
+               !BR2_ENABLE_LOCALE || \
                BR2_TOOLCHAIN_USES_UCLIBC
index 145ee618956521a5b4ebc23f3c93115c7947b3df..e97eaf224ec65b543a3d2bf3114f3fad32ffd8dd 100644 (file)
@@ -20,6 +20,10 @@ OPENVMTOOLS_CONF_OPTS = --with-dnet \
 OPENVMTOOLS_CONF_ENV += CUSTOM_DNET_CPPFLAGS=" "
 OPENVMTOOLS_DEPENDENCIES = host-nfs-utils libglib2 libdnet
 
+ifeq ($(BR2_PACKAGE_LIBTIRPC),y)
+OPENVMTOOLS_DEPENDENCIES += libtirpc
+endif
+
 # When libfuse is available, openvmtools can build vmblock-fuse, so
 # make sure that libfuse gets built first
 ifeq ($(BR2_PACKAGE_LIBFUSE),y)