package/log4cplus: add optional qt5 dependency
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sun, 3 Mar 2019 10:12:52 +0000 (11:12 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 7 Mar 2019 22:10:56 +0000 (23:10 +0100)
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
[Thomas: test BR2_PACKAGE_QT5BASE instead of BR2_PACKAGE_QT5, just for
consistency with the package we add to the DEPENDENCIES variable.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/log4cplus/log4cplus.mk

index 0bc4fc9aa697cc3b52330a5b343a146f094f83c6..82fc7135f49aa92b4a02065be232fd1122db484c 100644 (file)
@@ -11,6 +11,13 @@ LOG4CPLUS_LICENSE = Apache-2.0, BSD-2-Clause, BSD-like (threadpool)
 LOG4CPLUS_LICENSE_FILES = LICENSE
 LOG4CPLUS_INSTALL_STAGING = YES
 
+ifeq ($(BR2_PACKAGE_QT5BASE),y)
+LOG4CPLUS_DEPENDENCIES += host-pkgconf qt5base
+LOG4CPLUS_CONF_OPTS += --with-qt5
+else
+LOG4CPLUS_CONF_OPTS += --without-qt5
+endif
+
 ifeq ($(BR2_TOOLCHAIN_HAS_LIBATOMIC),y)
 LOG4CPLUS_CONF_ENV += LIBS='-latomic'
 endif