libmemcached: disable tests
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Sat, 19 Jul 2014 12:05:53 +0000 (09:05 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 19 Jul 2014 12:19:44 +0000 (14:19 +0200)
Disable test libraries and programs, even though it needs to autoreconf
it's a good tradeoff since it cuts the build time by half, and avoids
build issues with extra dependencies that aren't properly checked for.
Fixes:
http://autobuild.buildroot.net/results/739/739ae9b2f28486dec8900aa584145d2d38f44331/

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/libmemcached/libmemcached-01-disable-tests.patch [new file with mode: 0644]
package/libmemcached/libmemcached.mk

diff --git a/package/libmemcached/libmemcached-01-disable-tests.patch b/package/libmemcached/libmemcached-01-disable-tests.patch
new file mode 100644 (file)
index 0000000..d7da101
--- /dev/null
@@ -0,0 +1,16 @@
+Disable the tests, cuts build time by half and avoids build issues
+with extra dependencies.
+
+Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
+
+diff -Nura libmemcached-1.0.18.orig/Makefile.am libmemcached-1.0.18/Makefile.am
+--- libmemcached-1.0.18.orig/Makefile.am       2014-07-19 08:43:15.127031040 -0300
++++ libmemcached-1.0.18/Makefile.am    2014-07-19 08:48:11.327068987 -0300
+@@ -76,7 +76,6 @@
+ include libmemcachedinternal/util/include.am
+ include rpm/include.mk
+ include support/include.am
+-include tests/include.am
+ include util/include.am
+ include win32/include.am
index d901e7007203d51aa0e159c7eafc46cd96455a1b..fd5b4182f1398fc4aee72fd5461753b0db57216f 100644 (file)
@@ -11,6 +11,8 @@ LIBMEMCACHED_CONF_ENV = ac_cv_prog_cc_c99='-std=gnu99'
 LIBMEMCACHED_CONF_OPT = --disable-dtrace
 LIBMEMCACHED_INSTALL_STAGING = YES
 LIBMEMCACHED_DEPENDENCIES = $(if $(BR2_PACKAGE_LIBEVENT),libevent)
+# For libmemcached-01-disable-tests.patch
+LIBMEMCACHED_AUTORECONF = YES
 LIBMEMCACHED_LICENSE = BSD-3c
 LIBMEMCACHED_LICENSE_FILES = COPYING