lzlib: new package
authorFrancois Perrad <fperrad@gmail.com>
Mon, 24 Feb 2014 07:34:57 +0000 (08:34 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 1 Mar 2014 15:51:39 +0000 (16:51 +0100)
[Thomas: reformat Config.in help text to have a reasonable width of
the text.]

Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/lzlib/Config.in [new file with mode: 0644]
package/lzlib/lzlib.mk [new file with mode: 0644]

index 43c82922761cf5b0d80b68088c8732352abca383..bfc6f58f5b12f1cf4d4681153ad088ccb7e52cba 100644 (file)
@@ -396,6 +396,7 @@ source "package/lualogging/Config.in"
 source "package/luaposix/Config.in"
 source "package/luasec/Config.in"
 source "package/luasocket/Config.in"
+source "package/lzlib/Config.in"
 source "package/orbit/Config.in"
 source "package/rings/Config.in"
 source "package/wsapi/Config.in"
diff --git a/package/lzlib/Config.in b/package/lzlib/Config.in
new file mode 100644 (file)
index 0000000..d2b4818
--- /dev/null
@@ -0,0 +1,10 @@
+config BR2_PACKAGE_LZLIB
+       bool "lzlib"
+       select BR2_PACKAGE_ZLIB
+       depends on BR2_PACKAGE_HAS_LUA_INTERPRETER
+       help
+         This package provides a library to access zlib library
+         functions and also to read/write gzip files using an
+         interface similar to the base io package.
+
+         http://luaforge.net/projects/lzlib/
diff --git a/package/lzlib/lzlib.mk b/package/lzlib/lzlib.mk
new file mode 100644 (file)
index 0000000..24208ba
--- /dev/null
@@ -0,0 +1,12 @@
+#############################################################
+#
+# lzlib
+#
+#############################################################
+
+LZLIB_VERSION = 0.4.work3-1
+LZLIB_SUBDIR  = lzlib-0.4-work3
+LZLIB_DEPENDENCIES = zlib
+LZLIB_LICENSE = MIT
+
+$(eval $(luarocks-package))