Fixup util-linux so it actually compiles
authorEric Andersen <andersen@codepoet.org>
Wed, 3 Dec 2003 22:49:02 +0000 (22:49 -0000)
committerEric Andersen <andersen@codepoet.org>
Wed, 3 Dec 2003 22:49:02 +0000 (22:49 -0000)
make/util-linux.mk
sources/util-linux.patch [new file with mode: 0644]

index d1ac18ccad984045942c6f754b5d5b44e85841e3..ce6753a0c2519ce76c37b132e5deb1547c2bf2a9 100644 (file)
@@ -15,6 +15,7 @@ $(DL_DIR)/$(UTIL-LINUX_SOURCE):
 
 $(UTIL-LINUX_DIR)/.unpacked: $(DL_DIR)/$(UTIL-LINUX_SOURCE)
        $(UTIL-LINUX_CAT) $(DL_DIR)/$(UTIL-LINUX_SOURCE) | tar -C $(BUILD_DIR) -xvf -
+       cat $(SOURCE_DIR)/util-linux.patch | patch -p1 -d $(UTIL-LINUX_DIR)
        touch $(UTIL-LINUX_DIR)/.unpacked
 
 $(UTIL-LINUX_DIR)/.configured: $(UTIL-LINUX_DIR)/.unpacked
diff --git a/sources/util-linux.patch b/sources/util-linux.patch
new file mode 100644 (file)
index 0000000..601e7dc
--- /dev/null
@@ -0,0 +1,28 @@
+--- util-linux-2.11z/mount/fstab.c.orig        2003-12-03 15:28:22.000000000 -0700
++++ util-linux-2.11z/mount/fstab.c     2003-12-03 15:28:41.000000000 -0700
+@@ -342,7 +342,7 @@
+ /* Ensure that the lock is released if we are interrupted.  */
+ static void
+ handler (int sig) {
+-     die (EX_USER, "%s", sys_siglist[sig]);
++     die (EX_USER, "%s", strsignal(sig));
+ }
+ static void
+--- /dev/null  2003-09-07 01:55:59.000000000 -0600
++++ util-linux-2.11z/mount/swapargs.h  2003-12-03 15:44:50.000000000 -0700
+@@ -0,0 +1,3 @@
++#define SWAPON_HAS_TWO_ARGS
++#include <asm/page.h>
++#include <sys/swap.h>
+--- util-linux-2.11z/mount/swap.configure.orig 2003-12-03 15:43:24.000000000 -0700
++++ util-linux-2.11z/mount/swap.configure      2003-12-03 15:45:33.000000000 -0700
+@@ -1,6 +1,8 @@
+ # Find out whether we can include <sys/swap.h>
+ # and whether libc thinks that swapon() has two arguments.
++exit 0
++
+ # Prepare test
+ CC=${CC-cc}
+ compile="$CC -o conftest conftest.c >/dev/null 2>&1"