wireshark: avoid host qtchooser
authorBaruch Siach <baruch@tkos.co.il>
Tue, 18 Oct 2016 11:26:31 +0000 (14:26 +0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 19 Oct 2016 21:01:22 +0000 (23:01 +0200)
Some distros provide a 'qtchooser' utility to select Qt library
version. Make sure not to use that host provided utility.

Cc: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/wireshark/wireshark.mk

index ce83d5230e5b801b1da43308ae0b63745bbb88de..b1ef3f55c45b3f1989b99353ef743d9278fdf597 100644 (file)
@@ -41,6 +41,7 @@ endif
 ifeq ($(BR2_PACKAGE_QT5BASE_WIDGETS),y)
 WIRESHARK_CONF_OPTS += --with-qt=5
 WIRESHARK_DEPENDENCIES += qt5base
+WIRESHARK_CONF_ENV += ac_cv_path_QTCHOOSER=""
 # Seems it expects wrappers and passes a -qt=X parameter for version
 WIRESHARK_MAKE_OPTS += \
        MOC="$(HOST_DIR)/usr/bin/moc" \