package/busybox: invert dependency with net-tools
authorYann E. MORIN <yann.morin.1998@free.fr>
Sun, 8 Jul 2018 09:45:49 +0000 (11:45 +0200)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Sun, 8 Jul 2018 11:08:04 +0000 (13:08 +0200)
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
Cc: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/busybox/busybox.mk
package/net-tools/net-tools.mk

index eeb9dc5bacd8d71337c61c2ed9bd1f40fe518d0a..451aae46a52ce8515292ad81b65556bd3cf01778 100644 (file)
@@ -22,6 +22,7 @@ BUSYBOX_LDFLAGS = \
 
 # Packages that provide commands that may also be busybox applets:
 BUSYBOX_DEPENDENCIES = \
+       $(if $(BR2_PACKAGE_NET_TOOLS),net-tools) \
        $(if $(BR2_PACKAGE_NETCAT),netcat) \
        $(if $(BR2_PACKAGE_NETCAT_OPENSBSD),netcat-openbsd) \
        $(if $(BR2_PACKAGE_NMAP),nmap) \
index adab475b35c25209f587ad5f101519a74e5f3301..985fe2e35e7c363b6332415b04e51cd7fee67b58 100644 (file)
@@ -10,11 +10,6 @@ NET_TOOLS_DEPENDENCIES = $(TARGET_NLS_DEPENDENCIES)
 NET_TOOLS_LICENSE = GPL-2.0+
 NET_TOOLS_LICENSE_FILES = COPYING
 
-# Install after busybox for the full-blown versions
-ifeq ($(BR2_PACKAGE_BUSYBOX),y)
-NET_TOOLS_DEPENDENCIES += busybox
-endif
-
 define NET_TOOLS_CONFIGURE_CMDS
        (cd $(@D); yes "" | ./configure.sh config.in )
 endef
@@ -40,7 +35,8 @@ define NET_TOOLS_BUILD_CMDS
 endef
 
 # install renames conflicting binaries, update does not
-# ifconfig & route reside in /sbin for busybox
+# ifconfig & route reside in /sbin for busybox, so ensure we don't end
+# up with two versions of those.
 define NET_TOOLS_INSTALL_TARGET_CMDS
        $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) DESTDIR=$(TARGET_DIR) update
        mv -f $(TARGET_DIR)/bin/ifconfig $(TARGET_DIR)/sbin/ifconfig