nasm: bump version to 2.10.01, remove dummy target package
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 17 Jul 2012 18:03:53 +0000 (20:03 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 17 Jul 2012 18:03:53 +0000 (20:03 +0200)
The target package was only present because at the time 'nasm' was
packaged, there was a bug in the package infrastructure that prevented
a package from having a host only variant. This has been fixed since
then, so we can get rid of the useless dummy target package.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/nasm/nasm.mk

index b819df04b22282aa57aceed1583d0201c30dc513..9d99209055c5897f9583ffbdfd5eb3991d357613 100644 (file)
@@ -2,17 +2,10 @@
 #
 # nasm
 #
-# This is special case: nasm is used to build syslinux and
-# pxelinux. As these are for the target, we should cross-compile
-# nasm. However, as nasm is x86-only, there's no point in
-# cross-compiling it. So we just build it for the host. The target
-# variant is only provided because of a bug in the package
-# infrastructure that prevents having only a host variant.
 ############################################################
 
-NASM_VERSION=2.08.01
-NASM_SOURCE=nasm-$(NASM_VERSION).tar.bz2
-NASM_SITE=http://www.nasm.us/pub/nasm/releasebuilds/2.08.01/
+NASM_VERSION = 2.10.01
+NASM_SOURCE  = nasm-$(NASM_VERSION).tar.bz2
+NASM_SITE    = http://www.nasm.us/pub/nasm/releasebuilds/$(NASM_VERSION)
 
-$(eval $(call AUTOTARGETS))
 $(eval $(call AUTOTARGETS,host))