qt53d: enable assimpsceneparser plugin
authorPeter Seiderer <ps.report@gmx.net>
Sun, 21 Feb 2016 21:01:28 +0000 (22:01 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 23 Feb 2016 21:18:42 +0000 (22:18 +0100)
- add hint to help text
- add assimp dependency
- always install the gltf (and any future) sceneparser to target.

Signed-off-by: Peter Seiderer <ps.report@gmx.net>
Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Tested-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
[Thomas: update commit message as suggested by Arnout.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/qt5/qt53d/Config.in
package/qt5/qt53d/qt53d.mk

index b2d2912d5b2156b38ad8f7fb91917783510b69d3..ff50204fc80b98d29063bc42033dacb24c72271c 100644 (file)
@@ -12,6 +12,8 @@ config BR2_PACKAGE_QT53D
 
          This package corresponds to the qt53d module.
 
+         Enable the assimp package to gain the assimp sceneparser plugin.
+
          http://doc.qt.io/qt-5/qt3d-index.html
 
 comment "qt53d module needs an OpenGL-capable backend"
index 810242b449ed25114965c36cc3cbc1f9175ae09a..24c42e673dfa3f62f397e1a01c3a48f7cbb74beb 100644 (file)
@@ -10,6 +10,10 @@ QT53D_SOURCE = qt3d-opensource-src-$(QT5SVG_VERSION).tar.xz
 QT53D_DEPENDENCIES = qt5base qt5declarative
 QT53D_INSTALL_STAGING = YES
 
+ifeq ($(BR2_PACKAGE_ASSIMP),y)
+QT53D_DEPENDENCIES += assimp
+endif
+
 ifeq ($(BR2_PACKAGE_QT5BASE_LICENSE_APPROVED),y)
 QT53D_LICENSE = GPLv2+ or LGPLv3
 QT53D_LICENSE_FILES = LICENSE.GPL LICENSE.LGPLv3
@@ -34,6 +38,7 @@ endef
 ifeq ($(BR2_STATIC_LIBS),)
 define QT53D_INSTALL_TARGET_CMDS
        cp -dpf $(STAGING_DIR)/usr/lib/libQt53D*.so.* $(TARGET_DIR)/usr/lib
+       cp -dpfr $(STAGING_DIR)/usr/lib/qt/plugins/sceneparsers $(TARGET_DIR)/usr/lib/qt/plugins
        cp -dpfr $(STAGING_DIR)/usr/qml/Qt3D $(TARGET_DIR)/usr/qml
 endef
 endif