libuci: new package
authorYegor Yefremov <yegorslists@googlemail.com>
Thu, 20 Mar 2014 22:17:11 +0000 (23:17 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 23 Mar 2014 21:33:09 +0000 (22:33 +0100)
[Peter: needs !static, use += for _CONF_OPT]
Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/Config.in
package/libuci/Config.in [new file with mode: 0644]
package/libuci/libuci.mk [new file with mode: 0644]

index 66ded0b4a507d6b96351a7b8741f442485b7d79a..cfa53d3154ba5767ad6e5d52537257457cadf4d4 100644 (file)
@@ -792,6 +792,7 @@ source "package/libsigsegv/Config.in"
 source "package/libtasn1/Config.in"
 source "package/libtpl/Config.in"
 source "package/libubox/Config.in"
+source "package/libuci/Config.in"
 source "package/libunwind/Config.in"
 source "package/liburcu/Config.in"
 source "package/linux-pam/Config.in"
diff --git a/package/libuci/Config.in b/package/libuci/Config.in
new file mode 100644 (file)
index 0000000..761ae6e
--- /dev/null
@@ -0,0 +1,16 @@
+config BR2_PACKAGE_LIBUCI
+       bool "libuci"
+       depends on !BR2_PREFER_STATIC_LIB
+       select BR2_PACKAGE_LIBUBOX
+       help
+         This library originates from the OpenWrt project to
+         handle the configuration file infrastructure, but can
+         also be used for the same purposes in projects other
+         than OpenWrt.
+
+         This package will also install CLI tool uci.
+
+         http://wiki.openwrt.org/doc/techref/uci
+
+comment "libuci needs a toolchain w/ dynamic library"
+       depends on BR2_PREFER_STATIC_LIB
diff --git a/package/libuci/libuci.mk b/package/libuci/libuci.mk
new file mode 100644 (file)
index 0000000..736b946
--- /dev/null
@@ -0,0 +1,19 @@
+################################################################################
+#
+# libuci
+#
+################################################################################
+
+LIBUCI_VERSION = 262fede3e8c8c08c1eb0d1be9bf102232fb86cb9
+LIBUCI_SITE = git://nbd.name/uci.git
+LIBUCI_LICENSE = LGPLv2.1
+LIBUCI_INSTALL_STAGING = YES
+LIBUCI_DEPENDENCIES = libubox
+
+ifeq ($(BR2_PACKAGE_LUA),y)
+       LIBUCI_DEPENDENCIES += lua
+else
+       LIBUCI_CONF_OPT += -DBUILD_LUA:BOOL=OFF
+endif
+
+$(eval $(cmake-package))