package/libvirt: fix build with lvm2
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sat, 4 Sep 2021 09:54:03 +0000 (11:54 +0200)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Sat, 11 Sep 2021 19:52:30 +0000 (21:52 +0200)
libvirt needs a lvm2 standard install since its addition in commit
ccfc90e1010e42e6529afae3a5ea8bf7226dabc1 to avoid the following build
failure:

../output-1/build/libvirt-7.4.0/meson.build:1831:6: ERROR: Program 'pvcreate' not found

Fixes:
 - http://autobuild.buildroot.org/results/dc9af7a677af7e53c1240ebbee5b0edc84c8cf52

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/libvirt/libvirt.mk

index 1b420771f56ad8c0d4221cae16fafc5ea69b4ed5..847c35e06e97c458b36f518110a24d893c84c780 100644 (file)
@@ -166,7 +166,7 @@ else
 LIBVIRT_CONF_OPTS += -Dselinux=disabled -Dsecdriver_selinux=disabled
 endif
 
-ifeq ($(BR2_PACKAGE_LVM2),y)
+ifeq ($(BR2_PACKAGE_LVM2_STANDARD_INSTALL),y)
 LIBVIRT_CONF_OPTS += -Dstorage_lvm=enabled
 LIBVIRT_DEPENDENCIES += lvm2
 else