New package: cJSON
authorDanomi Manchego <danomimanchego123@gmail.com>
Tue, 12 Jun 2012 16:40:32 +0000 (16:40 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 13 Jun 2012 06:44:41 +0000 (08:44 +0200)
Signed-off-by: Danomi Manchego <danomimanchego123@gmail.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Config.in
package/cjson/Config.in [new file with mode: 0644]
package/cjson/cjson.mk [new file with mode: 0644]

index b3a2f8011729bca076399defc4d46946fe200edf..ddb504a12cf16a801db9c046ec4ea2f06e63e5a5 100644 (file)
@@ -469,6 +469,7 @@ source "package/slang/Config.in"
 endmenu
 
 menu "JSON/XML"
+source "package/cjson/Config.in"
 source "package/expat/Config.in"
 source "package/ezxml/Config.in"
 source "package/json-c/Config.in"
diff --git a/package/cjson/Config.in b/package/cjson/Config.in
new file mode 100644 (file)
index 0000000..ff90074
--- /dev/null
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_CJSON
+       bool "cJSON"
+       help
+         An ultra-lightweight, portable, single-file, simple-as-can-be ANSI-C
+         compliant JSON parser, under MIT license.
+
+         http://cjson.sourceforge.net/
diff --git a/package/cjson/cjson.mk b/package/cjson/cjson.mk
new file mode 100644 (file)
index 0000000..f0e1fc4
--- /dev/null
@@ -0,0 +1,43 @@
+#############################################################
+#
+# cjson
+#
+#############################################################
+CJSON_VERSION         = undefined
+CJSON_SOURCE          = cJSONFiles.zip
+CJSON_SITE            = http://$(BR2_SOURCEFORGE_MIRROR).dl.sourceforge.net/project/cjson/
+CJSON_INSTALL_STAGING = YES
+
+define CJSON_EXTRACT_CMDS
+       unzip -d $(@D) $(DL_DIR)/$(CJSON_SOURCE)
+endef
+
+define CJSON_BUILD_CMDS
+       cd $(@D)/cJSON && $(TARGET_CC) $(TARGET_CFLAGS) -shared -fpic cJSON.c -o libcJSON.so
+endef
+
+define CJSON_INSTALL_STAGING_CMDS
+       $(INSTALL) -D $(@D)/cJSON/cJSON.h $(STAGING_DIR)/usr/include/cJSON.h
+       $(INSTALL) -D $(@D)/cJSON/libcJSON.so $(STAGING_DIR)/usr/lib/libcJSON.so
+endef
+
+define CJSON_INSTALL_TARGET_CMDS
+       $(INSTALL) -D $(@D)/cJSON/cJSON.h $(STAGING_DIR)/usr/include/cJSON.h
+       $(INSTALL) -D $(@D)/cJSON/libcJSON.so $(TARGET_DIR)/usr/lib/libcJSON.so
+endef
+
+define CJSON_UNINSTALL_STAGING_CMDS
+       rm -f $(STAGING_DIR)/usr/include/cJSON.h
+       rm -f $(STAGING_DIR)/usr/lib/libcJSON.so
+endef
+
+define CJSON_UNINSTALL_TARGET_CMDS
+       rm -f $(TARGET_DIR)/usr/include/cJSON.h
+       rm -f $(TARGET_DIR)/usr/lib/libcJSON.so
+endef
+
+define CJSON_CLEAN_CMDS
+       cd $(@D)/cJSON && rm -f libcJSON.so
+endef
+
+$(eval $(call GENTARGETS))