libxml-parser-perl: fix host-intltool breakage when microperl is enabled
authorPeter Korsgaard <jacmet@sunsite.dk>
Tue, 27 Mar 2012 15:11:36 +0000 (17:11 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Tue, 27 Mar 2012 15:28:34 +0000 (17:28 +0200)
Microperl will build host-microperl and install it into HOST_DIR/usr/bin,
where other packages will pick it up as _CONFIGURE_OPTS / _MAKE_ENV
prepends that to the path.

libxml-parser-perl didn't though, so it would still be built against
the system perl, causing host-intltool to fail when it would use
host-microperl together with libxml-parser-perl if the system perl
isn't compatible with host-microperl.

Fix it by using HOST_CONFIGURE_OPTS and ensuring it is built after
(host-)microperl if enabled.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/libxml-parser-perl/libxml-parser-perl.mk

index 9e6f2ecc85ac7b9fc81874c72d294a0565089254..1022302bb9bf8935e38dcf93510c4d439339c873 100644 (file)
@@ -9,9 +9,15 @@ LIBXML_PARSER_PERL_SITE:=http://www.cpan.org/modules/by-module/XML/
 
 LIBXML_PARSER_PERL_DEPENDENCIES = expat
 
+ifeq ($(BR2_PACKAGE_MICROPERL),y)
+# microperl builds host-microperl, so ensure we build after that to build
+# against host-microperl instead of the system perl
+LIBXML_PARSER_PERL_DEPENDENCIES += microperl
+endif
+
 define HOST_LIBXML_PARSER_PERL_CONFIGURE_CMDS
  (cd $(@D) ; \
-   perl Makefile.PL \
+   $(HOST_CONFIGURE_OPTS) perl Makefile.PL \
         PREFIX=$(HOST_DIR)/usr \
         EXPATLIBPATH=$(HOST_DIR)/usr/lib \
         EXPATINCPATH=$(HOST_DIR)/usr/include \