package/environment-setup: Fix incorrect order of the `sed` expressions
authorMircea GLIGA <mgliga@bitdefender.com>
Sun, 16 May 2021 14:19:49 +0000 (17:19 +0300)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Tue, 18 May 2021 20:22:29 +0000 (22:22 +0200)
Order of the `sed` expressions is important; when this was commited
to master, the order of the expressions from the original patch [1] was
changed, rendering the second expression to noop.

This made all the environment variables from the script to contain
absolute paths: long absolute paths makes verbose builds difficult
to read/follow.
We can take advantage of the fact that the PATH is updated and we
don't have to use absolute paths.

Fixed by reordering the `sed` expresions:
* first update the path of the binaries: e.g. 's%$(HOST_DIR)/bin/%%g'
* only then update remaining paths: e.g. 's%$(HOST_DIR)%\$$SDK_PATH%g'

[1] https://patchwork.ozlabs.org/project/buildroot/patch/20201027140140.47982-1-matthew.weber@rockwellcollins.com/

Signed-off-by: Mircea GLIGA <mgliga@bitdefender.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/environment-setup/environment-setup.mk

index fcad013f0decfcd80e2dcf960f370e0cdc14f572..f4c52921f72c2d81e21dcada84ea86250335000f 100644 (file)
@@ -26,8 +26,8 @@ define HOST_ENVIRONMENT_SETUP_INSTALL_CMDS
        printf "alias cmake=\"cmake \
                -DCMAKE_TOOLCHAIN_FILE=$(HOST_DIR)/share/buildroot/toolchainfile.cmake \
                -DCMAKE_INSTALL_PREFIX=/usr\"\n" >> $(ENVIRONMENT_SETUP_FILE)
-       $(SED) 's%$(HOST_DIR)%\$$SDK_PATH%g' \
-               -e 's%$(HOST_DIR)/bin/%%g' \
+       $(SED) 's%$(HOST_DIR)/bin/%%g' \
+               -e 's%$(HOST_DIR)%\$$SDK_PATH%g' \
                -e '/^export "PATH=/c\' \
                $(ENVIRONMENT_SETUP_FILE)
        printf "export \"PATH=\$$SDK_PATH/bin:\$$SDK_PATH/sbin:\$$PATH\"\n" \