mesa3d: fix build without dri drivers
authorPeter Korsgaard <peter@korsgaard.com>
Sun, 28 Sep 2014 20:45:10 +0000 (22:45 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 28 Sep 2014 20:45:10 +0000 (22:45 +0200)
If no dri drivers are enabled, then mesa shouldn't get built with dri
support.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Acked-by: Bernd Kuhls <bernd.kuhls@t-online.de>
package/mesa3d/mesa3d.mk

index 8fc507555585a01e82f97ae9067e7eac2a3f941c..ec76872c82b7dfd73eec9e854534e54f2ef7dd1a 100644 (file)
@@ -75,7 +75,7 @@ endif
 
 ifeq ($(MESA3D_DRI_DRIVERS-y),)
 MESA3D_CONF_OPT += \
-       --without-dri-drivers
+       --without-dri-drivers --without-dri
 else
 ifeq ($(BR2_PACKAGE_XPROTO_DRI3PROTO),y)
 MESA3D_DEPENDENCIES += xlib_libxshmfence xproto_dri3proto xproto_presentproto