package/xenomai: add support to download from a custom git tree
authorJan Kiszka <jan.kiszka@siemens.com>
Tue, 14 Jan 2020 20:55:21 +0000 (21:55 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 24 Jun 2020 21:21:28 +0000 (23:21 +0200)
Soem versions are tagged, but not tarballed, so we need to be able to
retrieve them from git.

Usually, we do not have a default value for the repository, but unlike
for the kernel or the various bootloaders, the most prominent repository
for Xeniomai is upstream's official one (for the reason above, amongst
others), so we use that as a default.

Signed-off-by: Jan Kiszka <jan.kiszka@siemens.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
Cc: Romain Naour <romain.naour@gmail.com>
Cc: Thomas De Schampheleire <thomas.de_schampheleire@nokia.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/xenomai/Config.in
package/xenomai/xenomai.mk

index 326e1be737f4a6aa4f881b0862036d0d9b60e29f..452b45203963af7a1a631ef7c2881899f22265bb 100644 (file)
@@ -58,8 +58,16 @@ config BR2_PACKAGE_XENOMAI_CUSTOM_VERSION
 config BR2_PACKAGE_XENOMAI_CUSTOM_TARBALL
        bool "Custom tarball"
 
+config BR2_PACKAGE_XENOMAI_CUSTOM_GIT
+       bool "Custom Git repository"
+
 endchoice
 
+config BR2_PACKAGE_XENOMAI_REPOSITORY
+       string "URL of custom repository"
+       default "https://gitlab.denx.de/Xenomai/xenomai.git"
+       depends on BR2_PACKAGE_XENOMAI_CUSTOM_GIT
+
 config BR2_PACKAGE_XENOMAI_VERSION
        string "Custom Xenomai version" if !BR2_PACKAGE_XENOMAI_LATEST_VERSION
        default "3.0.10" if BR2_PACKAGE_XENOMAI_LATEST_VERSION
index d169c2e3155451c233ee83d72d8ca8d0d845cc3e..11c69000df3ba9c9ffc736df5ded2789fbb97861 100644 (file)
@@ -9,6 +9,9 @@ ifeq ($(BR2_PACKAGE_XENOMAI_CUSTOM_TARBALL),y)
 XENOMAI_TARBALL = $(call qstrip,$(BR2_PACKAGE_XENOMAI_CUSTOM_TARBALL_URL))
 XENOMAI_SOURCE = $(notdir $(XENOMAI_TARBALL))
 XENOMAI_SITE = $(patsubst %/,%,$(dir $(XENOMAI_TARBALL)))
+else ifeq ($(BR2_PACKAGE_XENOMAI_CUSTOM_GIT),y)
+XENOMAI_SITE = $(call qstrip,$(BR2_PACKAGE_XENOMAI_REPOSITORY))
+XENOMAI_SITE_METHOD = git
 else
 XENOMAI_SOURCE = xenomai-$(XENOMAI_VERSION).tar.bz2
 XENOMAI_SITE = http://xenomai.org/downloads/xenomai/stable