rename dropbear_sshd to just dropbear
authorMike Frysinger <vapier@gentoo.org>
Sat, 29 Oct 2005 07:01:33 +0000 (07:01 -0000)
committerMike Frysinger <vapier@gentoo.org>
Sat, 29 Oct 2005 07:01:33 +0000 (07:01 -0000)
package/Config.in
package/dropbear/Config.in [new file with mode: 0644]
package/dropbear/dropbear-init.patch [new file with mode: 0644]
package/dropbear/dropbear.mk [new file with mode: 0644]
package/dropbear_sshd/Config.in [deleted file]
package/dropbear_sshd/dropbear-init.patch [deleted file]
package/dropbear_sshd/dropbear_sshd.mk [deleted file]

index c65f3f4b781503df93090796c7f578171b288334..9745d8e7d8d3f71b8187e2d58c853cad68be9000 100644 (file)
@@ -37,7 +37,7 @@ source "package/directfb/Config.in"
 source "package/distcc/Config.in"
 source "package/dm/Config.in"
 source "package/dnsmasq/Config.in"
-source "package/dropbear_sshd/Config.in"
+source "package/dropbear/Config.in"
 source "package/e2fsprogs/Config.in"
 source "package/fakeroot/Config.in"
 source "package/file/Config.in"
diff --git a/package/dropbear/Config.in b/package/dropbear/Config.in
new file mode 100644 (file)
index 0000000..a545001
--- /dev/null
@@ -0,0 +1,21 @@
+config BR2_PACKAGE_DROPBEAR
+       bool "dropbear"
+       default n
+       help
+         A small SSH 2 server designed for small memory environments.
+
+         http://matt.ucc.asn.au/dropbear/dropbear.html
+
+config BR2_PACKAGE_DROPBEAR_URANDOM
+       bool "  Use /dev/urandom (low entropy systems only)?"
+       default n
+       depends on BR2_PACKAGE_DROPBEAR
+       help
+         By default, dropbear uses the much more secure /dev/random.  If you
+         are using a system lacking usable entropy sources, this could cause
+         the dropbear ssh daemon to block forever waiting for entropy that
+         will never arrive.  By making dropbear use /dev/urandom, you can
+         prevent Dropbear from blocking while waiting on the random device.
+         This could however significantly reduce the security of your ssh
+         connections.  Make sure you know what you are doing if you enable
+         this option -- most people should answer N.
diff --git a/package/dropbear/dropbear-init.patch b/package/dropbear/dropbear-init.patch
new file mode 100644 (file)
index 0000000..d6bf174
--- /dev/null
@@ -0,0 +1,59 @@
+--- dropbear-0.42/S50dropbear
++++ dropbear-0.42/S50dropbear
+@@ -0,0 +1,56 @@
++#!/bin/sh
++#
++# Starts dropbear sshd.
++#
++
++# Make sure the dropbearkey progam exists
++[ -f /usr/bin/dropbearkey ] || exit 0
++
++# Check for the Dropbear RSA key
++if [ ! -f /etc/dropbear/dropbear_rsa_host_key ] ; then
++      echo Generating RSA Key...
++      mkdir -p /etc/dropbear
++      /usr/bin/dropbearkey -t rsa -f /etc/dropbear/dropbear_rsa_host_key
++fi
++
++# Check for the Dropbear DSS key
++if [ ! -f /etc/dropbear/dropbear_dss_host_key ] ; then
++      echo Generating DSS Key...
++      mkdir -p /etc/dropbear
++      /usr/bin/dropbearkey -t dss -f /etc/dropbear/dropbear_dss_host_key
++fi
++
++umask 077
++
++start() {
++      echo -n "Starting dropbear sshd: "
++      start-stop-daemon --start --quiet --pidfile /var/run/dropbear.pid --exec /usr/sbin/dropbear
++      echo "OK"
++}
++stop() {
++      echo -n "Stopping sshd: "
++      start-stop-daemon --stop --quiet --pidfile /var/run/dropbear.pid
++      echo "OK"
++}
++restart() {
++      stop
++      start
++}
++
++case "$1" in
++  start)
++      start
++      ;;
++  stop)
++      stop
++      ;;
++  restart|reload)
++      restart
++      ;;
++  *)
++      echo $"Usage: $0 {start|stop|restart}"
++      exit 1
++esac
++
++exit $?
++
diff --git a/package/dropbear/dropbear.mk b/package/dropbear/dropbear.mk
new file mode 100644 (file)
index 0000000..e0b2f91
--- /dev/null
@@ -0,0 +1,93 @@
+#############################################################
+#
+# dropbear
+#
+#############################################################
+DROPBEAR_VER:=0.46
+DROPBEAR_SOURCE:=dropbear-$(DROPBEAR_VER).tar.bz2
+DROPBEAR_SITE:=http://matt.ucc.asn.au/dropbear/releases/
+DROPBEAR_DIR:=$(BUILD_DIR)/dropbear-$(DROPBEAR_VER)
+DROPBEAR_CAT:=bzcat
+DROPBEAR_BINARY:=dropbearmulti
+DROPBEAR_TARGET_BINARY:=usr/sbin/dropbear
+
+$(DL_DIR)/$(DROPBEAR_SOURCE):
+        $(WGET) -P $(DL_DIR) $(DROPBEAR_SITE)/$(DROPBEAR_SOURCE)
+
+dropbear-source: $(DL_DIR)/$(DROPBEAR_SOURCE)
+
+$(DROPBEAR_DIR)/.unpacked: $(DL_DIR)/$(DROPBEAR_SOURCE)
+       $(DROPBEAR_CAT) $(DL_DIR)/$(DROPBEAR_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
+       toolchain/patch-kernel.sh $(DROPBEAR_DIR) package/dropbear/ dropbear\*.patch
+       $(SED) 's,^/\* #define DROPBEAR_MULTI.*,#define DROPBEAR_MULTI,g' $(DROPBEAR_DIR)/options.h
+       touch $(DROPBEAR_DIR)/.unpacked
+
+$(DROPBEAR_DIR)/.configured: $(DROPBEAR_DIR)/.unpacked
+       (cd $(DROPBEAR_DIR); rm -rf config.cache; \
+               autoconf; \
+               $(TARGET_CONFIGURE_OPTS) \
+               CFLAGS="$(TARGET_CFLAGS)" \
+               ./configure \
+               --target=$(GNU_TARGET_NAME) \
+               --host=$(GNU_TARGET_NAME) \
+               --build=$(GNU_HOST_NAME) \
+               --prefix=/usr \
+               --exec-prefix=/usr \
+               --bindir=/usr/bin \
+               --sbindir=/usr/sbin \
+               --libexecdir=/usr/lib \
+               --sysconfdir=/etc \
+               --datadir=/usr/share \
+               --localstatedir=/var \
+               --mandir=/usr/man \
+               --infodir=/usr/info \
+               $(DISABLE_NLS) \
+               --with-shared \
+       );
+ifeq ($(strip $(BR2_PACKAGE_DROPBEAR_URANDOM)),y)
+       $(SED) 's,^#define DROPBEAR_RANDOM_DEV.*,#define DROPBEAR_RANDOM_DEV \"/dev/urandom\",' \
+               $(DROPBEAR_DIR)/options.h
+endif
+       touch  $(DROPBEAR_DIR)/.configured
+
+$(DROPBEAR_DIR)/$(DROPBEAR_BINARY): $(DROPBEAR_DIR)/.configured
+       $(MAKE) $(TARGET_CONFIGURE_OPTS) LD=$(TARGET_CC) \
+               PROGRAMS="dropbear dbclient dropbearkey dropbearconvert scp" \
+               MULTI=1 SCPPROGRESS=1 -C $(DROPBEAR_DIR)
+
+$(TARGET_DIR)/$(DROPBEAR_TARGET_BINARY): $(DROPBEAR_DIR)/$(DROPBEAR_BINARY)
+       #$(MAKE) DESTDIR=$(TARGET_DIR) $(TARGET_CONFIGURE_OPTS) \
+       #       LD=$(TARGET_CC) -C $(DROPBEAR_DIR) install
+       #rm -rf $(TARGET_DIR)/share/locale $(TARGET_DIR)/usr/info \
+       #       $(TARGET_DIR)/usr/man $(TARGET_DIR)/usr/share/doc
+       install -d -m 755 $(TARGET_DIR)/usr/sbin
+       install -d -m 755 $(TARGET_DIR)/usr/bin
+       install -m 755 $(DROPBEAR_DIR)/$(DROPBEAR_BINARY) \
+               $(TARGET_DIR)/$(DROPBEAR_TARGET_BINARY)
+       $(STRIP) $(TARGET_DIR)/$(DROPBEAR_TARGET_BINARY)
+       ln -snf ../sbin/dropbear $(TARGET_DIR)/usr/bin/scp
+       ln -snf ../sbin/dropbear $(TARGET_DIR)/usr/bin/ssh
+       ln -snf ../sbin/dropbear $(TARGET_DIR)/usr/bin/dbclient
+       ln -snf ../sbin/dropbear $(TARGET_DIR)/usr/bin/dropbearkey
+       ln -snf ../sbin/dropbear $(TARGET_DIR)/usr/bin/dropbearconvert
+       cp $(DROPBEAR_DIR)/S50dropbear $(TARGET_DIR)/etc/init.d/
+       chmod a+x $(TARGET_DIR)/etc/init.d/S50dropbear
+
+dropbear: uclibc zlib $(TARGET_DIR)/$(DROPBEAR_TARGET_BINARY)
+
+dropbear-clean:
+       $(MAKE) DESTDIR=$(TARGET_DIR) $(TARGET_CONFIGURE_OPTS) \
+               LD=$(TARGET_CC) -C $(DROPBEAR_DIR) uninstall
+       -$(MAKE) -C $(DROPBEAR_DIR) clean
+
+dropbear-dirclean:
+       rm -rf $(DROPBEAR_DIR)
+
+#############################################################
+#
+# Toplevel Makefile options
+#
+#############################################################
+ifeq ($(strip $(BR2_PACKAGE_DROPBEAR_SSHD)),y)
+TARGETS+=dropbear
+endif
diff --git a/package/dropbear_sshd/Config.in b/package/dropbear_sshd/Config.in
deleted file mode 100644 (file)
index 99d4496..0000000
+++ /dev/null
@@ -1,21 +0,0 @@
-config BR2_PACKAGE_DROPBEAR_SSHD
-       bool "dropbear_sshd"
-       default n
-       help
-         A small SSH 2 server designed for small memory environments.
-
-         http://matt.ucc.asn.au/dropbear/
-
-config BR2_PACKAGE_DROPBEAR_SSHD_URANDOM
-       bool "  Use /dev/urandom (low entropy systems only)?"
-       default n
-       depends on BR2_PACKAGE_DROPBEAR_SSHD
-       help
-         By default, dropbear uses the much more secure /dev/random.  If you
-         are using a system lacking usable entropy sources, this could cause
-         the dropbear ssh daemon to block forever waiting for entropy that
-         will never arrive.  By making dropbear use /dev/urandom, you can
-         prevent Dropbear from blocking while waiting on the random device.
-         This could however significantly reduce the security of your ssh
-         connections.  Make sure you know what you are doing if you enable
-         this option -- most people should answer N.
diff --git a/package/dropbear_sshd/dropbear-init.patch b/package/dropbear_sshd/dropbear-init.patch
deleted file mode 100644 (file)
index d6bf174..0000000
+++ /dev/null
@@ -1,59 +0,0 @@
---- dropbear-0.42/S50dropbear
-+++ dropbear-0.42/S50dropbear
-@@ -0,0 +1,56 @@
-+#!/bin/sh
-+#
-+# Starts dropbear sshd.
-+#
-+
-+# Make sure the dropbearkey progam exists
-+[ -f /usr/bin/dropbearkey ] || exit 0
-+
-+# Check for the Dropbear RSA key
-+if [ ! -f /etc/dropbear/dropbear_rsa_host_key ] ; then
-+      echo Generating RSA Key...
-+      mkdir -p /etc/dropbear
-+      /usr/bin/dropbearkey -t rsa -f /etc/dropbear/dropbear_rsa_host_key
-+fi
-+
-+# Check for the Dropbear DSS key
-+if [ ! -f /etc/dropbear/dropbear_dss_host_key ] ; then
-+      echo Generating DSS Key...
-+      mkdir -p /etc/dropbear
-+      /usr/bin/dropbearkey -t dss -f /etc/dropbear/dropbear_dss_host_key
-+fi
-+
-+umask 077
-+
-+start() {
-+      echo -n "Starting dropbear sshd: "
-+      start-stop-daemon --start --quiet --pidfile /var/run/dropbear.pid --exec /usr/sbin/dropbear
-+      echo "OK"
-+}
-+stop() {
-+      echo -n "Stopping sshd: "
-+      start-stop-daemon --stop --quiet --pidfile /var/run/dropbear.pid
-+      echo "OK"
-+}
-+restart() {
-+      stop
-+      start
-+}
-+
-+case "$1" in
-+  start)
-+      start
-+      ;;
-+  stop)
-+      stop
-+      ;;
-+  restart|reload)
-+      restart
-+      ;;
-+  *)
-+      echo $"Usage: $0 {start|stop|restart}"
-+      exit 1
-+esac
-+
-+exit $?
-+
diff --git a/package/dropbear_sshd/dropbear_sshd.mk b/package/dropbear_sshd/dropbear_sshd.mk
deleted file mode 100644 (file)
index d59e09b..0000000
+++ /dev/null
@@ -1,93 +0,0 @@
-#############################################################
-#
-# dropbear_sshd
-#
-#############################################################
-DROPBEAR_SSHD_VER:=0.46
-DROPBEAR_SSHD_SOURCE:=dropbear-$(DROPBEAR_SSHD_VER).tar.bz2
-DROPBEAR_SSHD_SITE:=http://matt.ucc.asn.au/dropbear/releases/
-DROPBEAR_SSHD_DIR:=$(BUILD_DIR)/dropbear-$(DROPBEAR_SSHD_VER)
-DROPBEAR_SSHD_CAT:=bzcat
-DROPBEAR_SSHD_BINARY:=dropbearmulti
-DROPBEAR_SSHD_TARGET_BINARY:=usr/sbin/dropbear
-
-
-$(DL_DIR)/$(DROPBEAR_SSHD_SOURCE):
-        $(WGET) -P $(DL_DIR) $(DROPBEAR_SSHD_SITE)/$(DROPBEAR_SSHD_SOURCE)
-
-dropbear_sshd-source: $(DL_DIR)/$(DROPBEAR_SSHD_SOURCE)
-
-$(DROPBEAR_SSHD_DIR)/.unpacked: $(DL_DIR)/$(DROPBEAR_SSHD_SOURCE)
-       $(DROPBEAR_SSHD_CAT) $(DL_DIR)/$(DROPBEAR_SSHD_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
-       toolchain/patch-kernel.sh $(DROPBEAR_SSHD_DIR) package/dropbear_sshd/ dropbear\*.patch
-       $(SED) 's,^/\* #define DROPBEAR_MULTI.*,#define DROPBEAR_MULTI,g' $(DROPBEAR_SSHD_DIR)/options.h
-       touch $(DROPBEAR_SSHD_DIR)/.unpacked
-
-$(DROPBEAR_SSHD_DIR)/.configured: $(DROPBEAR_SSHD_DIR)/.unpacked
-       (cd $(DROPBEAR_SSHD_DIR); rm -rf config.cache; \
-               autoconf; \
-               $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(TARGET_CFLAGS)" \
-               ./configure \
-               --target=$(GNU_TARGET_NAME) \
-               --host=$(GNU_TARGET_NAME) \
-               --build=$(GNU_HOST_NAME) \
-               --prefix=/usr \
-               --exec-prefix=/usr \
-               --bindir=/usr/bin \
-               --sbindir=/usr/sbin \
-               --libexecdir=/usr/lib \
-               --sysconfdir=/etc \
-               --datadir=/usr/share \
-               --localstatedir=/var \
-               --mandir=/usr/man \
-               --infodir=/usr/info \
-               $(DISABLE_NLS) \
-               --with-shared \
-       );
-ifeq ($(strip $(BR2_PACKAGE_DROPBEAR_SSHD_URANDOM)),y)
-       $(SED) 's,^#define DROPBEAR_RANDOM_DEV.*,#define DROPBEAR_RANDOM_DEV \"/dev/urandom\",' \
-               $(DROPBEAR_SSHD_DIR)/options.h
-endif
-       touch  $(DROPBEAR_SSHD_DIR)/.configured
-
-$(DROPBEAR_SSHD_DIR)/$(DROPBEAR_SSHD_BINARY): $(DROPBEAR_SSHD_DIR)/.configured
-       $(MAKE) $(TARGET_CONFIGURE_OPTS) LD=$(TARGET_CC) \
-               PROGRAMS="dropbear dbclient dropbearkey dropbearconvert scp" \
-               MULTI=1 SCPPROGRESS=1 -C $(DROPBEAR_SSHD_DIR)
-
-$(TARGET_DIR)/$(DROPBEAR_SSHD_TARGET_BINARY): $(DROPBEAR_SSHD_DIR)/$(DROPBEAR_SSHD_BINARY)
-       #$(MAKE) DESTDIR=$(TARGET_DIR) $(TARGET_CONFIGURE_OPTS) \
-       #       LD=$(TARGET_CC) -C $(DROPBEAR_SSHD_DIR) install
-       #rm -rf $(TARGET_DIR)/share/locale $(TARGET_DIR)/usr/info \
-       #       $(TARGET_DIR)/usr/man $(TARGET_DIR)/usr/share/doc
-       install -d -m 755 $(TARGET_DIR)/usr/sbin
-       install -d -m 755 $(TARGET_DIR)/usr/bin
-       install -m 755 $(DROPBEAR_SSHD_DIR)/$(DROPBEAR_SSHD_BINARY) \
-               $(TARGET_DIR)/$(DROPBEAR_SSHD_TARGET_BINARY)
-       $(STRIP) $(TARGET_DIR)/$(DROPBEAR_SSHD_TARGET_BINARY)
-       ln -snf ../sbin/dropbear $(TARGET_DIR)/usr/bin/scp
-       ln -snf ../sbin/dropbear $(TARGET_DIR)/usr/bin/ssh
-       ln -snf ../sbin/dropbear $(TARGET_DIR)/usr/bin/dropbearkey
-       ln -snf ../sbin/dropbear $(TARGET_DIR)/usr/bin/dropbearconvert
-       cp $(DROPBEAR_SSHD_DIR)/S50dropbear $(TARGET_DIR)/etc/init.d/
-       chmod a+x $(TARGET_DIR)/etc/init.d/S50dropbear
-
-dropbear_sshd: uclibc zlib $(TARGET_DIR)/$(DROPBEAR_SSHD_TARGET_BINARY)
-
-dropbear_sshd-clean:
-       $(MAKE) DESTDIR=$(TARGET_DIR) $(TARGET_CONFIGURE_OPTS) \
-               LD=$(TARGET_CC) -C $(DROPBEAR_SSHD_DIR) uninstall
-       -$(MAKE) -C $(DROPBEAR_SSHD_DIR) clean
-
-dropbear_sshd-dirclean:
-       rm -rf $(DROPBEAR_SSHD_DIR)
-
-#############################################################
-#
-# Toplevel Makefile options
-#
-#############################################################
-ifeq ($(strip $(BR2_PACKAGE_DROPBEAR_SSHD)),y)
-TARGETS+=dropbear_sshd
-endif