openblas: pass ONLY_CBLAS=1 only when Fortran is not available
authorVicente Olivert Riera <Vincent.Riera@imgtec.com>
Mon, 4 Jul 2016 15:22:59 +0000 (16:22 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 4 Jul 2016 15:34:09 +0000 (17:34 +0200)
Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/openblas/openblas.mk

index d07d09dc99b42ef93436dce5ed8d0995f3ca9416..baeef05297eadb50944d1e4dca25c2d852d8ec55 100644 (file)
@@ -19,9 +19,10 @@ OPENBLAS_MAKE_OPTS += CROSS=1
 # Set OpenBLAS target
 OPENBLAS_MAKE_OPTS += TARGET=$(BR2_PACKAGE_OPENBLAS_TARGET)
 
-# Disable fortran by default until we add BR2_TOOLCHAIN_HAS_FORTRAN
-# hidden symbol to our toolchain infrastructure
+# When Fortran is not available, only build the C version of BLAS
+ifeq ($(BR2_TOOLCHAIN_HAS_FORTRAN),)
 OPENBLAS_MAKE_OPTS += ONLY_CBLAS=1
+endif
 
 # Enable/Disable multi-threading (not for static-only since it uses dlfcn.h)
 ifeq ($(BR2_TOOLCHAIN_HAS_THREADS):$(BR2_STATIC_LIBS),y:)