toolchain: fix helpers for POSIX compliance
authorYann E. MORIN <yann.morin.1998@anciens.enib.fr>
Mon, 20 Sep 2010 21:26:06 +0000 (23:26 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 30 Sep 2010 20:08:54 +0000 (22:08 +0200)
Using two '=' for string comparison is a bashism.
Revert to using one, as stated in POSIX 1003.1-2008.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@anciens.enib.fr>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
toolchain/helpers.mk

index 5c87d2bfaf4a24037834ff9121f9c0478aad30da..05d43e788bad22197b2b8e21245a57adb2efca48 100644 (file)
@@ -170,11 +170,11 @@ check_glibc = \
 #
 check_uclibc_feature = \
        IS_IN_LIBC=`grep -q "\#define $(1) 1" $(3) && echo y` ; \
-       if [ x$($(2)) != x"y" -a x$${IS_IN_LIBC} == x"y" ] ; then \
+       if [ x$($(2)) != x"y" -a x$${IS_IN_LIBC} = x"y" ] ; then \
                echo "$(4) available in C library, please enable $(2)" ; \
                exit 1 ; \
        fi ; \
-       if [ x$($(2)) == x"y" -a x$${IS_IN_LIBC} != x"y" ] ; then \
+       if [ x$($(2)) = x"y" -a x$${IS_IN_LIBC} != x"y" ] ; then \
                echo "$(4) not available in C library, please disable $(2)" ; \
                exit 1 ; \
        fi
@@ -214,11 +214,11 @@ check_arm_abi = \
        else \
                EXT_TOOLCHAIN_ABI="oabi" ; \
        fi ; \
-       if [ x$(BR2_ARM_OABI) == x"y" -a $${EXT_TOOLCHAIN_ABI} == "eabi" ] ; then \
+       if [ x$(BR2_ARM_OABI) = x"y" -a $${EXT_TOOLCHAIN_ABI} = "eabi" ] ; then \
                echo "Incorrect ABI setting" ; \
                exit 1 ; \
        fi ; \
-       if [ x$(BR2_ARM_EABI) == x"y" -a $${EXT_TOOLCHAIN_ABI} == "oabi" ] ; then \
+       if [ x$(BR2_ARM_EABI) = x"y" -a $${EXT_TOOLCHAIN_ABI} = "oabi" ] ; then \
                echo "Incorrect ABI setting" ; \
                exit 1 ; \
        fi ; \