jq: disable maintainer mode
authorThomas De Schampheleire <thomas.de.schampheleire@gmail.com>
Mon, 19 Oct 2015 10:42:08 +0000 (12:42 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 21 Oct 2015 20:37:11 +0000 (22:37 +0200)
Since version 1.5, maintainer mode is enabled by default. We don't need
this, and is in particular problematic because it requires bison 3.0.

Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/jq/jq.mk

index dd132768c540cdcbc80583f4e4c175b3871d27f5..8053e392f237c36eff2ae48228e990441d82553c 100644 (file)
@@ -12,4 +12,7 @@ JQ_LICENSE_FILES = COPYING
 # uses c99 specific features
 JQ_CONF_ENV += CFLAGS="$(TARGET_CFLAGS) -std=c99"
 
+# jq explicitly enables maintainer mode, which we don't need/want
+JQ_CONF_OPTS += --disable-maintainer-mode
+
 $(eval $(autotools-package))