gcc: support grahite only for GCC 5 or above
authorAndrey Yurovsky <yurovsky@gmail.com>
Tue, 1 Aug 2017 23:43:00 +0000 (16:43 -0700)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 2 Aug 2017 19:16:45 +0000 (21:16 +0200)
GCC 4.9.x requires an old version of ISL to support graphite, and this
old version of ISL is not sufficient to support graphite in modern GCC
versions.

Since GCC 4.9.x is getting older, and to keep things simple, we stop
supporting graphite on old GCC < 5.x. This way, we will be able to
bump ISL to a version that is suitable for modern GCC versions.

In addition, this allows to drop the dependency on cloog, which was
only needed for GCC 4.9.

Signed-off-by: Andrey Yurovsky <yurovsky@gmail.com>
[Thomas: rework commit log.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/gcc/Config.in.host
package/gcc/gcc.mk

index 768dc176ae5440a67c6262779d8a10613bbaf449..a2e02d7aedcfe3c615c90927ab67a4ccd6eaaf91 100644 (file)
@@ -159,6 +159,10 @@ config BR2_GCC_ENABLE_LIBMUDFLAP
 
 config BR2_GCC_ENABLE_GRAPHITE
        bool "Enable graphite support"
+       depends on BR2_TOOLCHAIN_GCC_AT_LEAST_5
        help
          This option enables the graphite optimizations in the
          compiler.
+
+comment "graphite support needs gcc >= 5.x"
+       depends on !BR2_TOOLCHAIN_GCC_AT_LEAST_5
index 67d3343efee234234af41a7e7f9ffbb114afd388..6ee840e3b95b100b28f75d49f7d44ab2418e71bf 100644 (file)
@@ -173,15 +173,12 @@ else
 HOST_GCC_COMMON_CONF_OPTS += --enable-threads
 endif
 
+# gcc 5 doesn't need cloog any more, see
+# https://gcc.gnu.org/gcc-5/changes.html and we don't support graphite
+# on GCC 4.9.x, so only isl is needed.
 ifeq ($(BR2_GCC_ENABLE_GRAPHITE),y)
 HOST_GCC_COMMON_DEPENDENCIES += host-isl
 HOST_GCC_COMMON_CONF_OPTS += --with-isl=$(HOST_DIR)
-# gcc 5 doesn't need cloog any more, see
-# https://gcc.gnu.org/gcc-5/changes.html
-ifeq ($(BR2_TOOLCHAIN_GCC_AT_LEAST_5),)
-HOST_GCC_COMMON_DEPENDENCIES += host-cloog
-HOST_GCC_COMMON_CONF_OPTS += --with-cloog=$(HOST_DIR)
-endif
 else
 HOST_GCC_COMMON_CONF_OPTS += --without-isl --without-cloog
 endif