Makefile: toolchain-eclipse-register: add toolchain dependency
authorFabio Porcedda <fabio.porcedda@gmail.com>
Fri, 18 Apr 2014 13:07:31 +0000 (15:07 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 20 Apr 2014 15:41:05 +0000 (17:41 +0200)
The "toolchain-eclipse-register" target needs the toolchain so add
toolchain as a dependency.
This also fix the support to top-level parallel make.

Signed-off-by: Fabio Porcedda <fabio.porcedda@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Makefile

index dd47f77ed693712912776c420d903f693e5f695a..c33368a9ce296d19b30ac3d83f0eb7535bd4d18f 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -621,7 +621,7 @@ target-post-image: $(TARGETS_ROOTFS) target-finalize
                $(call MESSAGE,"Executing post-image script $(s)"); \
                $(EXTRA_ENV) $(s) $(BINARIES_DIR) $(call qstrip,$(BR2_ROOTFS_POST_SCRIPT_ARGS))$(sep))
 
-toolchain-eclipse-register:
+toolchain-eclipse-register: toolchain
        ./support/scripts/eclipse-register-toolchain `readlink -f $(O)` $(notdir $(TARGET_CROSS)) $(BR2_ARCH)
 
 source: $(TARGETS_SOURCE) $(HOST_SOURCE)