openssl: fix libdir issue
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Thu, 3 Feb 2011 12:55:48 +0000 (09:55 -0300)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 23 Feb 2011 22:31:49 +0000 (23:31 +0100)
Closes #3205

OpenSSL's build system tries to be too wise for it's own good when
guessing what libdir should be.
This causes problems like the one reported in bug #3205 so just specify
libdir to point to /lib (since it's prefixed it would finally be
/usr/lib) since it should be present on 32 and 64 bit targets.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
CHANGES
package/openssl/openssl.mk

diff --git a/CHANGES b/CHANGES
index 925ef5d3090edd22d7c691fdef9e6a0fc01c364b..757754ed0d8bd93a7d6b67f20750290785d13a99 100644 (file)
--- a/CHANGES
+++ b/CHANGES
@@ -25,6 +25,7 @@
 
        Issues resolved (http://bugs.uclibc.org):
 
+       #3205: Failing chmod when running "make" in buildroot (openssl)...
        #3283: See why nfs-utils needs fakeroot, and convert to autotools
 
 2011.02-rc1, Released February 14th, 2011:
index bf924cbf6b9e3fe2a7fe931f2d92c7bafe0be28b..7bf347ad876c2bcdf65206a3426115067cd56924 100644 (file)
@@ -47,6 +47,7 @@ define OPENSSL_CONFIGURE_CMDS
                        linux-$(OPENSSL_TARGET_ARCH) \
                        --prefix=/usr \
                        --openssldir=/etc/ssl \
+                       --libdir=/lib \
                        threads \
                        shared \
                        no-idea \