package/kvm-unit-tests: drop x86_64 workaround
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Tue, 25 Feb 2020 17:30:28 +0000 (18:30 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 26 Feb 2020 19:47:47 +0000 (20:47 +0100)
This workaround is not needed since commit
0788e921f961e36a50a94f8bb98f7eb75b312245 which disables stack-protector
for all architectures as intended by upstream

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/kvm-unit-tests/kvm-unit-tests.mk

index 26370667010aeca4ff57f52f85e395af0a08ab33..d83d31d2ee4cae8543f57ecc417d88fb8532c126 100644 (file)
@@ -35,13 +35,7 @@ KVM_UNIT_TESTS_CONF_OPTS =\
 # compiler. However, for x86-64, we use the host compiler, as
 # kvm-unit-tests builds 32 bit code, which Buildroot toolchains for
 # x86-64 cannot do.
-ifeq ($(BR2_x86_64),y)
-# Arch Linux adds -fstack-protector even when building with -ffreestanding, but
-# it doesn't link with the stack-protector library when -nostdlib is passed,
-# which leads to a link error. Therefore, disable it explicitly to work around
-# this bug in Arch Linux. https://bugs.archlinux.org/task/64270
-KVM_UNIT_TESTS_MAKE_OPTS += EXTRA_CFLAGS=-fno-stack-protector
-else
+ifeq ($(BR2_x86_64),)
 KVM_UNIT_TESTS_CONF_OPTS += --cross-prefix="$(TARGET_CROSS)"
 endif