package/sentry-cli: remove package
authorThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 18 Aug 2021 20:22:12 +0000 (22:22 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Thu, 19 Aug 2021 20:48:14 +0000 (22:48 +0200)
This package has had build failures for a very long time, and these
issues have not been fixed, and it is now the number 1 build failure
reason in our autobuilders. It is time to acknowledge that the package
needs to be removed.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
DEVELOPERS
package/Config.in.host
package/sentry-cli/Config.in.host [deleted file]
package/sentry-cli/sentry-cli.hash [deleted file]
package/sentry-cli/sentry-cli.mk [deleted file]

index 5f90dbfc1f633a922e955384f05c76c7a3ae19e6..7d2fbf4cf36031b24fcde5dd00ee15aba636f0a2 100644 (file)
@@ -1444,7 +1444,6 @@ F:        package/python-schedule/
 F:     package/python-sentry-sdk/
 F:     package/python-websockets/
 F:     package/python-xlib/
-F:     package/sentry-cli/
 F:     package/sentry-native/
 F:     package/unclutter-xfixes/
 
index 8d443ea255eddb6ae8c23ddef348bc04de7bc8dc..551352482ef40348025a90c107311d0872504bcd 100644 (file)
@@ -79,7 +79,6 @@ menu "Host utilities"
        source "package/s6-rc/Config.in.host"
        source "package/sam-ba/Config.in.host"
        source "package/sdbusplus/Config.in.host"
-       source "package/sentry-cli/Config.in.host"
        source "package/squashfs/Config.in.host"
        source "package/sunxi-tools/Config.in.host"
        source "package/swig/Config.in.host"
diff --git a/package/sentry-cli/Config.in.host b/package/sentry-cli/Config.in.host
deleted file mode 100644 (file)
index 3124015..0000000
+++ /dev/null
@@ -1,10 +0,0 @@
-config BR2_PACKAGE_HOST_SENTRY_CLI
-       bool "host sentry-cli"
-       depends on BR2_PACKAGE_HOST_RUSTC_ARCH_SUPPORTS
-       select BR2_PACKAGE_HOST_RUSTC
-       help
-         Official Sentry command line interface
-
-         For managing debug information files and source maps.
-
-         https://docs.sentry.io/cli/
diff --git a/package/sentry-cli/sentry-cli.hash b/package/sentry-cli/sentry-cli.hash
deleted file mode 100644 (file)
index 3b0733a..0000000
+++ /dev/null
@@ -1,3 +0,0 @@
-# locally calculated
-sha256  5d0f7acf6a139d1c1716b9a8ff76c8bfaab09104ba663c957bb9a5dba2ffbabd  sentry-cli-1.57.0.tar.gz
-sha256  9503def7b54ceb6e3cd182fd59bc05d3a30d7eae481e65aaba4b495133c83c14  LICENSE
diff --git a/package/sentry-cli/sentry-cli.mk b/package/sentry-cli/sentry-cli.mk
deleted file mode 100644 (file)
index 7e53f16..0000000
+++ /dev/null
@@ -1,32 +0,0 @@
-################################################################################
-#
-# sentry-cli
-#
-################################################################################
-
-SENTRY_CLI_VERSION = 1.57.0
-SENTRY_CLI_SITE = $(call github,getsentry,sentry-cli,$(SENTRY_CLI_VERSION))
-SENTRY_CLI_LICENSE = BSD-3-clause
-SENTRY_CLI_LICENSE_FILES = LICENSE
-
-HOST_SENTRY_CLI_DEPENDENCIES = host-rustc host-zlib
-
-HOST_SENTRY_CLI_CARGO_ENV = \
-       CARGO_HOME=$(HOST_DIR)/share/cargo \
-       RUSTFLAGS="$(addprefix -C link-args=,$(HOST_LDFLAGS))"
-
-HOST_SENTRY_CLI_CARGO_OPTS = \
-       --release \
-       --manifest-path=$(@D)/Cargo.toml
-
-define HOST_SENTRY_CLI_BUILD_CMDS
-       $(HOST_MAKE_ENV) $(HOST_SENTRY_CLI_CARGO_ENV) \
-               cargo build $(HOST_SENTRY_CLI_CARGO_OPTS)
-endef
-
-define HOST_SENTRY_CLI_INSTALL_CMDS
-       $(INSTALL) -D -m 0755 $(@D)/target/release/sentry-cli \
-               $(HOST_DIR)/bin/sentry-cli
-endef
-
-$(eval $(host-generic-package))