dbus-python: add python3 support
authorPeter Korsgaard <peter@korsgaard.com>
Thu, 20 Nov 2014 13:53:31 +0000 (14:53 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 22 Nov 2014 18:15:11 +0000 (19:15 +0100)
[Thomas: update the dependencies of the comment to take into account
that we can now also build with Python 3.]

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/dbus-python/Config.in
package/dbus-python/dbus-python.mk

index a38d27794accae9209a40bfe817317b38377f6ae..332726348d33087629c556cd82cbff0932c54442 100644 (file)
@@ -3,15 +3,16 @@ config BR2_PACKAGE_DBUS_PYTHON
        depends on BR2_USE_WCHAR # glib2
        depends on BR2_TOOLCHAIN_HAS_THREADS # glib2
        depends on BR2_PACKAGE_DBUS
-       depends on BR2_PACKAGE_PYTHON
+       depends on BR2_PACKAGE_PYTHON || BR2_PACKAGE_PYTHON3
        select BR2_PACKAGE_DBUS_GLIB
        # pyexpat: runtime dependency only
-       select BR2_PACKAGE_PYTHON_PYEXPAT
+       select BR2_PACKAGE_PYTHON_PYEXPAT if BR2_PACKAGE_PYTHON
+       select BR2_PACKAGE_PYTHON3_PYEXPAT if BR2_PACKAGE_PYTHON3
        help
          Python bindings for D-Bus
 
          http://dbus.freedesktop.org/doc/dbus-python/
 
 comment "dbus-python needs a toolchain w/ wchar, threads"
-       depends on BR2_PACKAGE_DBUS && BR2_PACKAGE_PYTHON
+       depends on BR2_PACKAGE_DBUS && (BR2_PACKAGE_PYTHON || BR2_PACKAGE_PYTHON3)
        depends on !BR2_USE_WCHAR || !BR2_TOOLCHAIN_HAS_THREADS
index bc57689823a25091a4db9c7407e22e8fbf3f7eda..1637406c0f3e34f46f4dbc364ec26f8974a849ae 100644 (file)
@@ -9,14 +9,25 @@ DBUS_PYTHON_SITE = http://dbus.freedesktop.org/releases/dbus-python
 DBUS_PYTHON_INSTALL_STAGING = YES
 DBUS_PYTHON_LICENSE = MIT
 DBUS_PYTHON_LICENSE_FILES = COPYING
+DBUS_PYTHON_DEPENDENCIES = dbus-glib
+DBUS_PYTHON_CONF_OPTS = --disable-html-docs --disable-api-docs
+
+ifeq ($(BR2_PACKAGE_PYTHON),y)
+DBUS_PYTHON_DEPENDENCIES += python host-python
 
-DBUS_PYTHON_CONF_ENV = \
+DBUS_PYTHON_CONF_ENV += \
        PYTHON=$(HOST_DIR)/usr/bin/python2 \
        PYTHON_INCLUDES="$(shell $(STAGING_DIR)/usr/bin/python2-config --includes)" \
        PYTHON_LIBS="$(shell $(STAGING_DIR)/usr/bin/python2-config --ldflags)"
+else
+DBUS_PYTHON_DEPENDENCIES += python3 host-python3
+
+DBUS_PYTHON_CONF_ENV += \
+       PYTHON=$(HOST_DIR)/usr/bin/python3 \
+       PYTHON_INCLUDES="$(shell $(STAGING_DIR)/usr/bin/python3-config --includes)" \
+       PYTHON_LIBS="$(shell $(STAGING_DIR)/usr/bin/python3-config --ldflags)"
+endif
 
-DBUS_PYTHON_CONF_OPTS = --disable-html-docs --disable-api-docs
 
-DBUS_PYTHON_DEPENDENCIES = dbus-glib python host-python
 
 $(eval $(autotools-package))