fs/squashfs: remove useless chmod
authorYann E. MORIN <yann.morin.1998@free.fr>
Mon, 6 Jun 2016 20:43:44 +0000 (22:43 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 7 Jun 2016 20:21:29 +0000 (22:21 +0200)
When that was added (in 975e30b, fs/squashfs: fix image file
permissions), the reasons were not quite explicit.

We are now forcing the umask, and various tests have shown that the mode
on the generated image file are correct without the chmod.

Remove it.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Peter Korsgaard <peter@korsgaard.com>
Acked-by: Peter Korsgaard <peter@korsgaard.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
fs/squashfs/squashfs.mk

index eadbb8fe8fd693dbe65d956645cf4d3973eba2d6..c4d9ca50b346c1d05a7e5210c6a4e3c2b84cccd4 100644 (file)
@@ -27,7 +27,6 @@ endif
 define ROOTFS_SQUASHFS_CMD
        $(HOST_DIR)/usr/bin/mksquashfs $(TARGET_DIR) $@ -noappend \
                $(ROOTFS_SQUASHFS_ARGS)
-       chmod 0644 $@
 endef
 
 $(eval $(call ROOTFS_TARGET,squashfs))