gdb: add host-texinfo dependency for Git versions
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 5 Dec 2013 17:20:59 +0000 (18:20 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 6 Dec 2013 21:48:51 +0000 (22:48 +0100)
Just like for binutils, gdb versions pulled from Git want to
regenerate their documentation, and none of the MAKEINFO tricks we've
tried worked properly, so we're simply adding host-texinfo as a
dependency.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/gdb/gdb.mk

index fbe16411388a270abf032ae7409cc4d19ad757f5..d06b61bd45b83985fe86849335f3536889c32261 100644 (file)
@@ -24,11 +24,13 @@ endif
 ifeq ($(BR2_arc),y)
 GDB_SITE = $(call github,foss-for-synopsys-dwc-arc-processors,gdb,$(GDB_VERSION))
 GDB_SOURCE = gdb-$(GDB_VERSION).tar.gz
+GDB_FROM_GIT = y
 endif
 
 ifeq ($(BR2_microblaze),y)
 GDB_SITE = $(call github,Xilinx,gdb,$(GDB_VERSION))
 GDB_SOURCE = gdb-$(GDB_VERSION).tar.gz
+GDB_FROM_GIT = y
 endif
 
 ifeq ($(GDB_VERSION),6.7.1-avr32-2.1.5)
@@ -126,6 +128,10 @@ HOST_GDB_CONF_OPT = \
        --without-included-gettext \
        --disable-sim
 
+ifeq ($(GDB_FROM_GIT),y)
+HOST_GDB_DEPENDENCIES += host-texinfo
+endif
+
 # legacy $arch-linux-gdb symlink
 define HOST_GDB_ADD_SYMLINK
        cd $(HOST_DIR)/usr/bin && \