net-snmp: fixup paths in net-snmp-config
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Mon, 2 May 2011 15:36:05 +0000 (12:36 -0300)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 2 May 2011 15:44:30 +0000 (17:44 +0200)
Exposed by commit 7e3e8ec040b06d6e2fb69e55c004f1ebc02c76d0
net-snmp-config goes for -L/usr/lib thus things break since this wins
over the sysroot if we have a host net-snmp library around when we build
packages that link against net-snmp.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/netsnmp/netsnmp.mk

index edb1704f71532683c28f3ede0841aa0519d872b9..5704327444c15bb4d886ff27f05caabcc3e3701e 100644 (file)
@@ -68,4 +68,14 @@ define NETSNMP_UNINSTALL_TARGET_CMDS
        rm -f $(TARGET_DIR)/usr/lib/libnetsnmp*
 endef
 
+define NETSNMP_STAGING_NETSNMP_CONFIG_FIXUP
+       $(SED) "s,^prefix=.*,prefix=\'$(STAGING_DIR)/usr\',g" \
+               -e "s,^exec_prefix=.*,exec_prefix=\'$(STAGING_DIR)/usr\',g" \
+               -e "s,^includedir=.*,includedir=\'$(STAGING_DIR)/usr/include\',g" \
+               -e "s,^libdir=.*,libdir=\'$(STAGING_DIR)/usr/lib\',g" \
+               $(STAGING_DIR)/usr/bin/net-snmp-config
+endef
+
+NETSNMP_POST_INSTALL_STAGING_HOOKS += NETSNMP_STAGING_NETSNMP_CONFIG_FIXUP
+
 $(eval $(call AUTOTARGETS,package,netsnmp))