package/cryptsetup: needs iconv
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sun, 28 Jun 2020 20:48:08 +0000 (22:48 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Mon, 29 Jun 2020 20:31:38 +0000 (22:31 +0200)
iconv is a mantadory dependency since version 2.3.0 and
https://github.com/mbroz/cryptsetup/commit/62c872eb4942ec37a18a37ea7cca1749757ddbb6

Fixes:
 - http://autobuild.buildroot.org/results/a13c4b64e8ac673df07d8dc1d33fae42a4f80fff

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/cryptsetup/Config.in
package/cryptsetup/cryptsetup.mk

index c4281f7e26b38dfa52402908cf3b212866167180..d9c9d4d4f4ec319794bab14680162dc510a03316 100644 (file)
@@ -11,6 +11,7 @@ config BR2_PACKAGE_CRYPTSETUP
        select BR2_PACKAGE_UTIL_LINUX_LIBBLKID
        select BR2_PACKAGE_JSON_C
        select BR2_PACKAGE_LIBARGON2
+       select BR2_PACKAGE_LIBICONV if !BR2_ENABLE_LOCALE
        help
          This tool helps manipulate dm-crypt and luks partitions for
          on-disk encryption.
index 587ef0a810c08a034ecca55f9e88c565a172b413..68cc1543dc6061db4189cd51c32999f2a7b70bf3 100644 (file)
@@ -9,6 +9,7 @@ CRYPTSETUP_VERSION = $(CRYPTSETUP_VERSION_MAJOR).3
 CRYPTSETUP_SOURCE = cryptsetup-$(CRYPTSETUP_VERSION).tar.xz
 CRYPTSETUP_SITE = $(BR2_KERNEL_MIRROR)/linux/utils/cryptsetup/v$(CRYPTSETUP_VERSION_MAJOR)
 CRYPTSETUP_DEPENDENCIES = lvm2 popt util-linux host-pkgconf json-c libargon2 \
+       $(if $(BR2_PACKAGE_LIBICONV),libiconv) \
        $(TARGET_NLS_DEPENDENCIES)
 CRYPTSETUP_LICENSE = GPL-2.0+ (programs), LGPL-2.1+ (library)
 CRYPTSETUP_LICENSE_FILES = COPYING COPYING.LGPL