ccache: expose control interface via 'make ccache-options'
authorTzu-Jung Lee <roylee17@gmail.com>
Thu, 10 Oct 2013 17:50:57 +0000 (10:50 -0700)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 27 Oct 2013 09:30:10 +0000 (10:30 +0100)
usage:
# set cache limit size
make CCACHE_OPTIONS="--max-size=5G" ccache-options

# zero statistics counters
make CCACHE_OPTIONS="--zero-stats" ccache-options

[Peter: drop the redundant ifeq]
Signed-off-by: Tzu-Jung Lee <tjlee@ambarella.com>
Acked-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
docs/manual/ccache-support.txt
package/ccache/ccache.mk

index 4969180a296762640547e193cc8bc65f96b4decc..fe06a01fafd3ead26f41c7d6df119cb97011ed82 100644 (file)
@@ -23,3 +23,14 @@ remove this directory.
 
 You can get statistics on the cache (its size, number of hits,
 misses, etc.) by running +make ccache-stats+.
+
+The make target +ccache-options+ and the +CCACHE_OPTIONS+ variable
+provide more generic access to the ccache. For example
+
+-----------------
+# set cache limit size
+make CCACHE_OPTIONS="--max-size=5G" ccache-options
+
+# zero statistics counters
+make CCACHE_OPTIONS="--zero-stats" ccache-options
+-----------------
index c5e93857c55c5c23ab0bf928dc6781d0cf47c9c1..82a53f34c9e2207fefe9033195e1e73f519253a2 100644 (file)
@@ -44,4 +44,13 @@ $(eval $(host-autotools-package))
 ifeq ($(BR2_CCACHE),y)
 ccache-stats: host-ccache
        $(Q)$(CCACHE) -s
+
+ccache-options: host-ccache
+ifeq ($(CCACHE_OPTIONS),)
+       $(Q)echo "Usage: make ccache-options CCACHE_OPTIONS=\"opts\""
+       $(Q)echo "where 'opts' corresponds to one or more valid ccache options" \
+       "(see ccache help text below)"
+       $(Q)echo
+endif
+       $(Q)$(CCACHE) $(CCACHE_OPTIONS)
 endif