uclibc: symlinks are now automatically created by uClibc-ng makefile
authorWaldemar Brodkorb <wbx@openadk.org>
Sat, 5 Sep 2015 15:25:22 +0000 (17:25 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 6 Sep 2015 09:37:09 +0000 (11:37 +0200)
So the workaround can be dropped now that we've moved to uClibc-ng 1.0.6.

[Peter: Extend commit message]
Signed-off-by: Waldemar Brodkorb <wbx@openadk.org>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/uclibc/uclibc.mk

index a2ba23017b4e54034e7d2bbd3ab3fe31ab81bbac..eaac9dc4033f24b496c0fc3105c75f1638799a2d 100644 (file)
@@ -434,21 +434,6 @@ define UCLIBC_INSTALL_UTILS_TARGET
 endef
 endif
 
-# gcc produces binaries that use ld{64,}-uClibc.so.0 as the program
-# interpreter, but since uClibc-ng version is 1.0.0, it generates
-# ld{64,}-uClibc.so.1. In order to avoid changing gcc, we simply
-# create the necessary symbolic links here.
-ifeq ($(BR2_UCLIBC_VERSION_NG),y)
-define UCLIBC_INSTALL_LDSO_SYMLINKS
-       if [ -e $(TARGET_DIR)/lib/ld64-uClibc.so.1 ]; then \
-               (cd $(TARGET_DIR)/lib;ln -sf ld64-uClibc.so.1 ld64-uClibc.so.0) \
-       fi
-       if [ -e $(TARGET_DIR)/lib/ld-uClibc.so.1 ]; then \
-               (cd $(TARGET_DIR)/lib;ln -sf ld-uClibc.so.1 ld-uClibc.so.0) \
-       fi
-endef
-endif
-
 define UCLIBC_INSTALL_TARGET_CMDS
        $(MAKE1) -C $(@D) \
                $(UCLIBC_MAKE_FLAGS) \