package/pkg-kconfig: fix reconfigure for kconfig packages
authorAngelo Compagnucci <angelo.compagnucci@gmail.com>
Tue, 26 Nov 2019 13:24:58 +0000 (14:24 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 5 Dec 2019 20:32:58 +0000 (21:32 +0100)
Commit 4b81badbcc0b25678ac6627548160702731cf393

    Currently, calling foo-reconfigure for a kconfig-based package will not
    re-trigger the configuration (kconfig-wise) step for the package.

was supposed to solve this problem and lately we had

Commit 05fea6e4a60a38a797d9bacbf318a2cd7dbd435f

    infra/pkg-kconfig: do not rely on package's .config as a timestamp

that introduced the .stamp_dotconfig file.

For this reason, to trigger a kconfig package reconfigure is now
necessary to remove the .stamp_dotconfig file.

Signed-off-by: Angelo Compagnucci <angelo@amarulasolutions.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/pkg-kconfig.mk

index e435b95bcf20e1ed9925e9a78ae15a9bb9da8633..e2d52ee8edcc573428ce543bbc80f88468a99341 100644 (file)
@@ -176,7 +176,7 @@ $$($(2)_TARGET_CONFIGURE): $$($(2)_DIR)/.stamp_kconfig_fixup_done
 $(1)-clean-for-reconfigure: $(1)-clean-kconfig-for-reconfigure
 
 $(1)-clean-kconfig-for-reconfigure:
-       rm -f $$($(2)_DIR)/.stamp_kconfig_fixup_done
+       rm -f $$($(2)_DIR)/$$($(2)_KCONFIG_STAMP_DOTCONFIG)
 
 # Only enable the foo-*config targets when the package is actually enabled.
 # Note: the variable $(2)_KCONFIG_VAR is not related to the kconfig