pure-ftpd: Added pure-ftpwho config option
authorBryce Ferguson <bryce.ferguson@rockwellcollins.com>
Mon, 19 Dec 2016 21:17:29 +0000 (15:17 -0600)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 20 Dec 2016 20:26:26 +0000 (21:26 +0100)
Added the pure-ftpwho config option. When selected, the --with-ftpwho
compiler option is passed which enabled the pure-ftpwho command.

Signed-off-by: Bryce Ferguson <bryce.ferguson@rockwellcollins.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/pure-ftpd/Config.in
package/pure-ftpd/pure-ftpd.mk

index c1b2529db9a4f58f82b27b7362c54e3f287728a1..85fdef30eb73f7cca5a74feed748c2c365310dd9 100644 (file)
@@ -10,3 +10,14 @@ config BR2_PACKAGE_PURE_FTPD
          well as hosting providers.
 
          http://www.pureftpd.org
+
+if BR2_PACKAGE_PURE_FTPD
+
+config BR2_PACKAGE_PURE_FTPD_FTPWHO
+       bool "ftpwho"
+       help
+         Enable the pure-ftpd command.  Pure-ftpwho shows current Pure-ftpd
+         client sessions.  Only the system administrator may run this.  Output
+         can be text (default), HTML, XML data and parser-optimized.
+
+endif
index ba4096c2813eb5310fed335f0b0b51c34b73abce..80e432af56f5b6a2a9989326cb38fc6d34b6287f 100644 (file)
@@ -45,4 +45,8 @@ ifeq ($(BR2_TOOLCHAIN_SUPPORTS_PIE),)
 PURE_FTPD_CONF_ENV += ax_cv_check_cflags___fPIE=no ax_cv_check_ldflags___fPIE=no
 endif
 
+ifeq ($(BR2_PACKAGE_PURE_FTPD_FTPWHO),y)
+PURE_FTPD_CONF_OPTS += --with-ftpwho
+endif
+
 $(eval $(autotools-package))