php: fpm: remove sample status page
authorFloris Bos <bos@je-eigen-domein.nl>
Mon, 18 May 2015 19:52:04 +0000 (21:52 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 19 May 2015 20:02:50 +0000 (22:02 +0200)
php-fpm installs a sample status page to $datadir/fpm/status.html
It is not of any use in that directory, so remove it from target.
If someone wants to use it, he can copy it to webroot manually.

Signed-off-by: Floris Bos <bos@je-eigen-domein.nl>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/php/php.mk

index 6e0e216ea0cef48eb26051387780f608ff128d54..3e4601ec5d3e504fbb7c0d1354a9ba5204c20893 100644 (file)
@@ -280,6 +280,8 @@ define PHP_INSTALL_FPM_CONF
        $(INSTALL) -D -m 0644 package/php/php-fpm.conf \
                $(TARGET_DIR)/etc/php-fpm.conf
        rm -f $(TARGET_DIR)/etc/php-fpm.conf.default
+       # remove unused sample status page /usr/php/php/fpm/status.html
+       rm -rf $(TARGET_DIR)/usr/php
 endef
 
 PHP_POST_INSTALL_TARGET_HOOKS += PHP_INSTALL_FPM_CONF