package/linux-headers: really drop the 4.17 choice
authorYann E. MORIN <yann.morin.1998@free.fr>
Thu, 4 Oct 2018 20:00:30 +0000 (22:00 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 7 Oct 2018 19:45:16 +0000 (21:45 +0200)
Currently, the build fails when the kernel headers 4.17 are selected:

    package/linux-headers/linux-headers.mk:149: *** LINUX_HEADERS_SITE
    cannot be empty when LINUX_HEADERS_SOURCE is not.  Stop.

This is caused by an hickup during the last merge of the next branch,
where the value for 4.17 got dropped from BR2_DEFAULT_KERNEL_HEADERS,
but the choice entry was left in.

The correct fix against that hickup would be to restore the 4.17 value.
But since 4.17 is no longer maintained, the proper fix is to really drop
4.17 altogether.

For good this time! ;-)

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Peter Korsgaard <peter@korsgaard.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Config.in.legacy
package/linux-headers/Config.in.host

index c942fd8e8141640465fec64e2e7af4c16008453b..c862532af235a476014f097cb9856514f490e5de 100644 (file)
@@ -200,6 +200,13 @@ config BR2_KERNEL_HEADERS_4_15
          Version 4.15.x of the Linux kernel headers are no longer
          maintained upstream and are now removed.
 
+config BR2_KERNEL_HEADERS_4_17
+       bool "kernel headers version 4.17.x are no longer supported"
+       select BR2_LEGACY
+       help
+         Version 4.17.x of the Linux kernel headers are no longer
+         maintained upstream and are now removed.
+
 ###############################################################################
 comment "Legacy options removed in 2018.08"
 
index 99f2954169849e85502a79ab32a597f6371597d5..7c9c1d0fb068e2840fd489fc2c478b1431eab79b 100644 (file)
@@ -56,10 +56,6 @@ config BR2_KERNEL_HEADERS_4_16
        bool "Linux 4.16.x kernel headers"
        select BR2_TOOLCHAIN_HEADERS_AT_LEAST_4_16
 
-config BR2_KERNEL_HEADERS_4_17
-       bool "Linux 4.17.x kernel headers"
-       select BR2_TOOLCHAIN_HEADERS_AT_LEAST_4_17
-
 config BR2_KERNEL_HEADERS_4_18
        bool "Linux 4.18.x kernel headers"
        select BR2_TOOLCHAIN_HEADERS_AT_LEAST_4_18