redis: bump to version 2.8.19
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Wed, 21 Jan 2015 12:21:42 +0000 (09:21 -0300)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 23 Jan 2015 15:45:38 +0000 (16:45 +0100)
Add hash file.
Drop redis-002-lua-AR.patch (upstream).
Rename patches to new naming convention.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/redis/0001-uclibc.patch [new file with mode: 0644]
package/redis/0002-largefile-conditional-define.patch [new file with mode: 0644]
package/redis/Config.in
package/redis/redis-001-uclibc.patch [deleted file]
package/redis/redis-002-lua-AR.patch [deleted file]
package/redis/redis-003-largefile-conditional-define.patch [deleted file]
package/redis/redis.hash [new file with mode: 0644]
package/redis/redis.mk

diff --git a/package/redis/0001-uclibc.patch b/package/redis/0001-uclibc.patch
new file mode 100644 (file)
index 0000000..01657d0
--- /dev/null
@@ -0,0 +1,45 @@
+redis-001-uclibc.patch: This patch fixes redis so that it can be compiled
+against uclibc.  Patch originates from:
+
+  Support cross-compiling for uClibc targets
+  https://github.com/antirez/redis/pull/537
+  Mike Steinert, mike.steinert@gmail.com
+
+Signed-off-by: Daniel Price <daniel.price@gmail.com>
+
+=========================================================================
+diff -ur old/src/config.h new/src/config.h
+--- old/src/config.h   2012-10-26 07:20:24.000000000 -0700
++++ new/src/config.h   2012-10-31 13:41:51.206309564 -0700
+@@ -1,6 +1,10 @@
+ #ifndef __CONFIG_H
+ #define __CONFIG_H
++#if defined(__unix) || defined(__linux__)
++#include <features.h>
++#endif
++
+ #ifdef __APPLE__
+ #include <AvailabilityMacros.h>
+ #endif
+@@ -25,7 +29,7 @@
+ #endif
+ /* Test for backtrace() */
+-#if defined(__APPLE__) || defined(__linux__)
++#if (defined(__APPLE__) || defined(__linux__) && !defined(__UCLIBC__))
+ #define HAVE_BACKTRACE 1
+ #endif
+diff -ur old/src/Makefile new/src/Makefile
+--- old/src/Makefile   2012-10-26 07:20:24.000000000 -0700
++++ new/src/Makefile   2012-10-31 13:40:39.224728830 -0700
+@@ -135,7 +135,7 @@
+       echo REDIS_LDFLAGS=$(REDIS_LDFLAGS) >> .make-settings
+       echo PREV_FINAL_CFLAGS=$(FINAL_CFLAGS) >> .make-settings
+       echo PREV_FINAL_LDFLAGS=$(FINAL_LDFLAGS) >> .make-settings
+-      -(cd ../deps && $(MAKE) $(DEPENDENCY_TARGETS))
++      -(cd ../deps && $(MAKE) CC="$(CC)" $(DEPENDENCY_TARGETS))
+ .PHONY: persist-settings
diff --git a/package/redis/0002-largefile-conditional-define.patch b/package/redis/0002-largefile-conditional-define.patch
new file mode 100644 (file)
index 0000000..747e055
--- /dev/null
@@ -0,0 +1,32 @@
+Define _LARGEFILE_SOURCE and _FILE_OFFSET_BITS conditionally
+
+In order to avoid ugly warnings at compile time, only define
+_LARGEFILE_SOURCE and _FILE_OFFSET_BITS if they have not already been
+defined through the build command line.
+
+Avoids:
+
+  In file included from redis.h:33:0,
+                   from migrate.c:1:
+  fmacros.h:45:0: warning: "_LARGEFILE_SOURCE" redefined
+  <command-line>:0:0: note: this is the location of the previous definition
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+
+Index: redis-2.6.11/src/fmacros.h
+===================================================================
+--- redis-2.6.11.orig/src/fmacros.h    2013-03-25 22:09:15.000000000 +0100
++++ redis-2.6.11/src/fmacros.h 2013-03-25 22:09:40.000000000 +0100
+@@ -42,7 +42,12 @@
+ #define _XOPEN_SOURCE
+ #endif
++#ifndef _LARGEFILE_SOURCE
+ #define _LARGEFILE_SOURCE
++#endif
++
++#ifndef _FILE_OFFSET_BITS
+ #define _FILE_OFFSET_BITS 64
++#endif
+ #endif
index b370e7dbbcb79e28aff40daa05ca23d7dec6f4bf..d2a7556f8a7e34316b613a8e685a919709437ac7 100644 (file)
@@ -3,6 +3,7 @@ config BR2_PACKAGE_REDIS
        depends on BR2_USE_MMU # fork()
        depends on BR2_TOOLCHAIN_HAS_THREADS
        depends on BR2_LARGEFILE
+       depends on BR2_INET_IPV6
        help
          Redis is an open source, advanced key-value store. It is
          often referred to as a data structure server since keys can
@@ -10,6 +11,7 @@ config BR2_PACKAGE_REDIS
 
          http://www.redis.io
 
-comment "redis needs a toolchain w/ largefile, threads"
+comment "redis needs a toolchain w/ IPv6, largefile, threads"
        depends on BR2_USE_MMU
-       depends on !BR2_LARGEFILE || !BR2_TOOLCHAIN_HAS_THREADS
+       depends on !BR2_LARGEFILE || !BR2_TOOLCHAIN_HAS_THREADS \
+               || !BR2_INET_IPV6
diff --git a/package/redis/redis-001-uclibc.patch b/package/redis/redis-001-uclibc.patch
deleted file mode 100644 (file)
index 01657d0..0000000
+++ /dev/null
@@ -1,45 +0,0 @@
-redis-001-uclibc.patch: This patch fixes redis so that it can be compiled
-against uclibc.  Patch originates from:
-
-  Support cross-compiling for uClibc targets
-  https://github.com/antirez/redis/pull/537
-  Mike Steinert, mike.steinert@gmail.com
-
-Signed-off-by: Daniel Price <daniel.price@gmail.com>
-
-=========================================================================
-diff -ur old/src/config.h new/src/config.h
---- old/src/config.h   2012-10-26 07:20:24.000000000 -0700
-+++ new/src/config.h   2012-10-31 13:41:51.206309564 -0700
-@@ -1,6 +1,10 @@
- #ifndef __CONFIG_H
- #define __CONFIG_H
-+#if defined(__unix) || defined(__linux__)
-+#include <features.h>
-+#endif
-+
- #ifdef __APPLE__
- #include <AvailabilityMacros.h>
- #endif
-@@ -25,7 +29,7 @@
- #endif
- /* Test for backtrace() */
--#if defined(__APPLE__) || defined(__linux__)
-+#if (defined(__APPLE__) || defined(__linux__) && !defined(__UCLIBC__))
- #define HAVE_BACKTRACE 1
- #endif
-diff -ur old/src/Makefile new/src/Makefile
---- old/src/Makefile   2012-10-26 07:20:24.000000000 -0700
-+++ new/src/Makefile   2012-10-31 13:40:39.224728830 -0700
-@@ -135,7 +135,7 @@
-       echo REDIS_LDFLAGS=$(REDIS_LDFLAGS) >> .make-settings
-       echo PREV_FINAL_CFLAGS=$(FINAL_CFLAGS) >> .make-settings
-       echo PREV_FINAL_LDFLAGS=$(FINAL_LDFLAGS) >> .make-settings
--      -(cd ../deps && $(MAKE) $(DEPENDENCY_TARGETS))
-+      -(cd ../deps && $(MAKE) CC="$(CC)" $(DEPENDENCY_TARGETS))
- .PHONY: persist-settings
diff --git a/package/redis/redis-002-lua-AR.patch b/package/redis/redis-002-lua-AR.patch
deleted file mode 100644 (file)
index 68ee70c..0000000
+++ /dev/null
@@ -1,32 +0,0 @@
-
-redis-002-lua-AR.patch: Improve redis Makefiles to handle Lua's unusual
-definition of AR.  Patch originates from:
-
-  Define AR to help with lua cross-compilation
-  https://github.com/antirez/redis/pull/997
-  Daniel Price, daniel.price@gmail.com
-
-Signed-off-by: Daniel Price <daniel.price@gmail.com>
-
-=========================================================================
-diff --git a/deps/Makefile b/deps/Makefile
-index d58ee56..c9d7116 100644
---- a/deps/Makefile
-+++ b/deps/Makefile
-@@ -60,10 +60,15 @@ endif
- LUA_CFLAGS+= -O2 -Wall -DLUA_ANSI $(CFLAGS)
- LUA_LDFLAGS+= $(LDFLAGS)
-+# lua's Makefile defines AR="ar rcu", which is unusual, and makes it more
-+# challenging to cross-compile lua (and redis).  These defines make it easier
-+# to fit redis into cross-compilation environments, which typically set AR.
-+AR = ar
-+ARFLAGS = rcu
- lua: .make-prerequisites
-       @printf '%b %b\n' $(MAKECOLOR)MAKE$(ENDCOLOR) $(BINCOLOR)$@$(ENDCOLOR)
--      cd lua/src && $(MAKE) all CFLAGS="$(LUA_CFLAGS)" MYLDFLAGS="$(LUA_LDFLAGS)"
-+      cd lua/src && $(MAKE) all CFLAGS="$(LUA_CFLAGS)" MYLDFLAGS="$(LUA_LDFLAGS)" AR="$(AR) $(ARFLAGS)"
- .PHONY: lua
diff --git a/package/redis/redis-003-largefile-conditional-define.patch b/package/redis/redis-003-largefile-conditional-define.patch
deleted file mode 100644 (file)
index 747e055..0000000
+++ /dev/null
@@ -1,32 +0,0 @@
-Define _LARGEFILE_SOURCE and _FILE_OFFSET_BITS conditionally
-
-In order to avoid ugly warnings at compile time, only define
-_LARGEFILE_SOURCE and _FILE_OFFSET_BITS if they have not already been
-defined through the build command line.
-
-Avoids:
-
-  In file included from redis.h:33:0,
-                   from migrate.c:1:
-  fmacros.h:45:0: warning: "_LARGEFILE_SOURCE" redefined
-  <command-line>:0:0: note: this is the location of the previous definition
-
-Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
-
-Index: redis-2.6.11/src/fmacros.h
-===================================================================
---- redis-2.6.11.orig/src/fmacros.h    2013-03-25 22:09:15.000000000 +0100
-+++ redis-2.6.11/src/fmacros.h 2013-03-25 22:09:40.000000000 +0100
-@@ -42,7 +42,12 @@
- #define _XOPEN_SOURCE
- #endif
-+#ifndef _LARGEFILE_SOURCE
- #define _LARGEFILE_SOURCE
-+#endif
-+
-+#ifndef _FILE_OFFSET_BITS
- #define _FILE_OFFSET_BITS 64
-+#endif
- #endif
diff --git a/package/redis/redis.hash b/package/redis/redis.hash
new file mode 100644 (file)
index 0000000..5f91766
--- /dev/null
@@ -0,0 +1,2 @@
+# Locally calculated
+sha256 29bb08abfc3d392b2f0c3e7f48ec46dd09ab1023f9a5575fc2a93546f4ca5145        redis-2.8.19.tar.gz
index 00490e72e0dc4993877116b51793bb2fc41d8539..4cad06147c324985213434c0c728857069fd29ce 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-REDIS_VERSION = 2.6.17
+REDIS_VERSION = 2.8.19
 REDIS_SITE = http://download.redis.io/releases
 REDIS_LICENSE = BSD-3c (core); MIT and BSD family licenses (Bundled components)
 REDIS_LICENSE_FILES = COPYING