tinyalsa: avoid install in /usr/local/
authorMaxime Hadjinlian <maxime.hadjinlian@gmail.com>
Fri, 4 Nov 2016 15:28:42 +0000 (16:28 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 5 Nov 2016 12:17:29 +0000 (13:17 +0100)
Set the PREFIX to avoid installing files in [...]/usr/local/.

Signed-off-by: Maxime Hadjinlian <maxime.hadjinlian@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/tinyalsa/tinyalsa.mk

index 4cd01d5d44036267a091c325f15c4852703f281f..87753d6f4e387f1089d124fb0294c73fccc8687d 100644 (file)
@@ -16,6 +16,7 @@ endef
 define TINYALSA_INSTALL_STAGING_CMDS
        $(TARGET_MAKE_ENV) $(MAKE) \
                -C $(@D) \
+               PREFIX="/usr" \
                CROSS_COMPILE="$(TARGET_CROSS)" \
                DESTDIR="$(STAGING_DIR)" install
 endef
@@ -23,6 +24,7 @@ endef
 define TINYALSA_INSTALL_TARGET_CMDS
        $(TARGET_MAKE_ENV) $(MAKE) \
                -C $(@D) \
+               PREFIX="/usr" \
                CROSS_COMPILE="$(TARGET_CROSS)" \
                DESTDIR="$(TARGET_DIR)" install
 endef