cramfs/jffs2: use the new ROOTFS_DEVICE_TABLE variable
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 17 Apr 2010 01:30:59 +0000 (03:30 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 17 Apr 2010 02:36:23 +0000 (04:36 +0200)
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
fs/cramfs/cramfs.mk
fs/jffs2/jffs2.mk

index ccd316f5d6796fae062123365296538b1e579ea8..e0deb7e2afe65f5989a689de3726acfb3fcb93bf 100644 (file)
@@ -9,8 +9,8 @@ else
 CRAMFS_OPTS=-l
 endif
 
-ifneq ($(TARGET_DEVICE_TABLE),)
-CRAMFS_OPTS += -D $(TARGET_DEVICE_TABLE)
+ifneq ($(ROOTFS_DEVICE_TABLE),)
+CRAMFS_OPTS += -D $(ROOTFS_DEVICE_TABLE)
 endif
 
 define ROOTFS_CRAMFS_CMD
index a0a563d185cad2027f2a299937085b34932bf655..36be03741cc3f0707dfb06e6203802c37e1265bc 100644 (file)
@@ -32,8 +32,8 @@ JFFS2_OPTS += -n
 SUMTOOL_OPTS += -n
 endif
 
-ifneq ($(TARGET_DEVICE_TABLE),)
-JFFS2_OPTS += -D $(TARGET_DEVICE_TABLE)
+ifneq ($(ROOTFS_DEVICE_TABLE),)
+JFFS2_OPTS += -D $(ROOTFS_DEVICE_TABLE)
 endif
 
 ROOTFS_JFFS2_DEPENDENCIES = host-mtd